The uploaded files are not saving with Save and Continue Later using Session URL

  • Profile Image
    alextrapp
    Asked on October 04, 2017 at 03:47 PM

    The last element I am experiementing with in saving and returning is the uploaded files.  It currently appears to me that the uploaded files are not saving, although I wasnt sure where they would even save to.

    After finding this thread: https://www.jotform.com/answers/84230-How-does-file-upload-work

    I now understand that we would probably set up a drop box integration, but is there a way to make that file save before submitting, or should I indicate to the participants that they upload files last?


    Thanks for the incredible customer service today!

  • Profile Image
    Welvin
    Answered on October 04, 2017 at 05:02 PM

    When you say it's not saving, you mean the file upload field(s) is not keeping the file or you mean they appear to be saved but when you submit, they are not showing up or they are broken?

    I got it to work on a test form here https://www.jotform.com/72756885299984?session=welvin. Perhaps, the saving just takes time? 

    Can you share the form? We'll check further. 

  • Profile Image
    alextrapp
    Answered on October 04, 2017 at 05:26 PM

    Welvin!  I continue to be impressed by your customer service response times!

    It does actually appear to be working, but does seem to take time.  This is not something we were thinking about as we were rapidly closing and opening the page.


    Thanks for your help!



  • Profile Image
    Welvin
    Answered on October 04, 2017 at 05:36 PM

    It's our pleasure to assist everyone promptly :)

    If the form consists of the few file upload fields, that is expected to take time. There is a loading/saving indicator at the bottom of the page, in the page break area. You have to wait for that icon to disappear before moving on. 

    This step is recommended for Save and Continue Later using the Session URL, especially for long forms.

    I just would like to confirm if you got it working now. Let us know.