My form is not submitting.

  • Profile Image
    NSTmosaic
    Asked on October 05, 2017 at 10:59 AM

    My form is not submitting. What did I do wrong?

    Thanks

  • Profile Image
    liyam
    Answered on October 05, 2017 at 11:51 AM

    I just tested your actual form, however, I was redirected to the Thank You page after clicking the submit button, which means that the form has been submitted successfully. Do you have the form embedded in some web page which may be having this issue? If not, can you confirm the link to the form which you are using for filling up?

    If the link to the form you have shared is the actual form you are trying to submit (https://www.jotform.com/build/72716328584161), please note that that is a link for building/editing forms. This means that the form in that mode will not do any submissions. You will need to go to the PUBLISH tab and get the link there

    Thanks.

  • Profile Image
    NSTmosaic
    Answered on October 05, 2017 at 12:06 PM

    Thank you.

    Here is the link to the website where we have this form. Thanks


  • Profile Image
    liyam
    Answered on October 05, 2017 at 12:24 PM

    Apparently, the link to the website appears to be not included on your response. Can you follow this link and post your reply here instead: https://www.jotform.com/answers/1265719

    Thanks.

  • Profile Image
    NSTmosaic
    Answered on October 05, 2017 at 12:26 PM
  • Profile Image
    liyam
    Answered on October 05, 2017 at 12:33 PM

    Thanks for the response and info. I see now what you mean.

    Can you try using the iframe embed code instead? You can check out this guide to know how to get the iframe embed code: https://www.jotform.com/help/148-Getting-the-Form-iFrame-Code

    If the problem persists, please let us know.