What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    Inconsistent conditions

    Asked by frankowen on May 02, 2010 at 06:34 AM
    Hi Aytekin

    I love the conditions but I have several forms where they have stopped working or only work on some of the conditions when I return to the form a day later or so.

    This form (http://www.jotform.com/?formID=1193632216) is such an example. It is a registration form for a conference and, when the user selects one of three payment options, the other two should hide. It was working well yesterday. Today, none of the conditions work.

    I have deleted all the conditions and tried restoring them one at a time (as you have suggested to another user) without success.

    Before I 'go live' with the form, I'd like to make sure that there is a reason for the user to select the payment type - otherwise, I may as well delete the field.

    On the same form, all the hover text has disappeared even though it is in the 'Show Properties' field as has the 'hint text'.

    I don't believe I'm doing anything wrong (I'm a user with over 12 months experience in Jotforms) but would really appreciate your advice.

    Thanks again

    Frank
  • Profile Image
    JotForm Founder

    Answered by aytekin on May 03, 2010 at 07:04 AM
    We will look into this problem and get back to you.


  • Profile Image

    Answered by egil500 on November 12, 2010 at 10:06 PM

    I had similar problems today, conditions did not work, later the same day they started to work as they should, is there something I should be aware of when using conditions?

  • Profile Image
    JotForm Founder

    Answered by aytekin on November 16, 2010 at 03:57 AM

    Usually the last condition you added might have broken the conditions. if you want us to take a look you must always send:

    1. URL of the form

    2. What action to perform to see condition not working

     

    If you have lots of conditions it is very difficult for us to understand the problem. The conditions might also conflict with each other or go into a loop. So, you should probably create a new form and add the condition that you expect to work but not, and send that to us.