Customizing submission PDF: The design of the titles are changed unexpectedly

  • Profile Image
    strykerssp
    Asked on October 09, 2017 at 11:45 PM

    Hi there,

    My PDF generated form is outputting different to how it usually does, and the text is small? 

    Usually my headers span across the PDF and are nice and bold, now they are returning to small text and the whole thing seems to be playing up depending on what browser I am using! (glitchy) 

    This is how I'd like the format to look: (LBMS part) 

    This is what the form is outputting now:


    Iv'e tried resetting the form, investigated the sizes etc, but the outputs are most erratic

    Would love some help if possible? 


    Kind regards,


    Eddie 


  • Profile Image
    candy
    Answered on October 10, 2017 at 03:57 AM

    Dear Eddie,

    We're sorry for the inconvenience you have. I have cloned your form named "LBMS" on my side in order to test it. I have fulfilled and submitted. 

    I have seen the logo in the submission PDF is too small. However, you are able to set it bigger in the customize PDF option as you can see the screenshot below:

    You can also set the texts centered as seen below:

    After saving it, the submission PDF will appear as seen below:

    Please be informed about that if you reset the PDF submission, all edits will be gone. So, do not reset it if you want to use the edited PDF submission.

    Please find the following guide in order to see how to customize submission PDF detailed: https://www.jotform.com/help/384-How-to-Customize-PDF-Submissions-Report 

    I hope this helps. 

  • Profile Image
    strykerssp
    Answered on October 12, 2017 at 07:31 AM

    Hi Candy, thanks for helping here,however, this doesn't fix my issue? 


    I need the header to appear in the centre and with a gray box arround it like it used too, also, the sub-header text has dissapeared? it just says 'LBMS' when it should say 'LBMS - QAS Test & Inspection Record' 


    The image is also glitchy, it keeps dissapearing when i try to adjust it. also, ALL headers in my form when published to a PDF are now small?

    appreciate some help here,


    Eddie :-) 

  • Profile Image
    candy
    Answered on October 12, 2017 at 09:30 AM

    Hello again Eddie,

    I have seen that the problem seems to be fixed and the PDF form appears as seen below:

    1507814640Screen_Shot_2017-10-12_at_4_22

    I have seen that there was an issue caused by some of our developers and it has been fixed again. Appologies again for the inconvenience.

    I have checked the submission PDF on your side and fixed it by resetting it. Everything is okay right now.

    Please check and let us know if you need any further assistance. 

    Thanks in advance for your understanding.

  • Profile Image
    strykerssp
    Answered on October 12, 2017 at 10:02 PM

    Hey Candy, thanks so much for your help,

     

    I am still not seeing any changes? The headers are still small/ non grayed out etc.

     

    what browser did you use to do the above?

     

    Kind regards,  Ed



  • Profile Image
    candy
    Answered on October 13, 2017 at 02:32 AM

    Dear Ed,

    Please find the following form URL that I have cloned from your account: https://www.jotform.com/72843751123959 When I download the submission PDF, it is shown as you preferred.

    I have used Mozilla Firefox in order to test, however, I do not think so it is due to the web browser. Could you please re-clone the same form on your end and check the submission PDF if it is seen below:

    1507876273Screen Shot 2017-10-13 at 9.31

    Let us know about the result.

    Thanks in advance.

  • Profile Image
    strykerssp
    Answered on October 16, 2017 at 12:27 AM

    Hi Candy, 


    It's still not working. When I clone the form I am getting the header in as you have pictured above...BUT as soon as I edit the PDF to get rid of the form title (and IP address) the logo reverts to being small, as does the header! Really frustrating now.. The problem only appears to arise once i need to edit the PDF to remove the form title etc. 

    Still feels like a bug to me.. Essentially what I am after (and how I have had all my forms up until now) is the 'Stryker' logo to be at the top (no IP address, or form title etc) and the headers to be gray and bold!

    Please help!

    Kind regards,


    Eddie


    1508127924Header.PNG

  • Profile Image
    candy
    Answered on October 16, 2017 at 02:53 AM

    Dear Eddie,

    Thank you for your effort in the detailed explanation of the problem. 

    First of all, you do not need to edit the submission PDF in order to remove the IP of the submission from submission PDF. You are able to remove it on Submission Page as you can see the screenshot below:

    1508135930Screen_Shot_2017-10-16_at_9_37

    I have checked the submission PDFs belongs to the cloned version of your form on your side and tested. It has some problems in the preview mode and in the edition mode as you can see the comparison below:

    1508136216errors-in-submission-edit-and-

    I have seen that the logo gets smaller in the edit mode. However, when I save the PDF again, the logo looks like the original as you have seen. 

    When I have downloaded the submission PDF via the link in the Thank You page, the design of the title is broken as seen below:

    1508136656Screen_Shot_2017-10-16_at_9_50

    I have forwarded these problems to our software development team in order to fix it.

    We are going to inform you as soon as the issue will be fixed.

    Thanks in advance for your patience.

  • Profile Image
    strykerssp
    Answered on October 18, 2017 at 01:14 AM

    Hi Candy, 


    The old Headers appear to be sort of working again, only now I have lost my 'Stryker' Logo from ALL my forms! Please Help! Are the team still working on things?

    The below picture is a screen shot of the PDF - it has the logo in it still but it appears to be missing..

    1508303432Screen Shot 2017-10-18 at 3.15


    This is what happens when I re-add the logo (below) 

    1508303525Screen Shot 2017-10-18 at 3.16


    The PDF is out of whack! 

    Below is how things look when i jump into the 'customize pdf' section, notice the logo space is present but the logo isn't? 

    1508303614Screen Shot 2017-10-18 at 3.15


    Please could you advise? I have customers panicking due to the missing logo/issues


    Many thanks,

    Eddie 

  • Profile Image
    candy
    Answered on October 18, 2017 at 04:04 AM

    Dear Eddie,

    Our software developer is still working on this ticket.

    We are going to inform you as soon as this problem will be solved. 

    Thanks in advance for your patience. 

  • Profile Image
    Helen
    Answered on October 18, 2017 at 04:59 AM

    Hello Eddie,

    First of all thank you for reporting this issue.

    Your issue with Header&Text field and Images on the submission PDF has been fixed now.

    Thank you,

  • Profile Image
    Eddie  
    Answered on October 18, 2017 at 07:14 AM

    Thank you so much Helen - Really appreciate it! You have made my day!


    Kind regards, 


    eddie