Submission PDF: "Show headers and texts" option is not showing in the Submissions page

  • Profile Image
    TycenDemolitions
    Asked on October 16, 2017 at 12:10 AM

    HI

    I have some static text in the end of my form that i would like to have included in the form response PDF.

    It used to work until recently. Around 10/10/2017 form submission stopped including the static text with the submission PDF. I tried un-ticking and re-ticking the the Show headers and texts option but the text still not included in the submission. i tried adding the text again but its not working. i tried reverting to an older version of the form from revision history and it still did not work when i restored a known working version.

    I have attached an image with a screenshot where the OFFICE USE ONLY static text section is included in the PDF on the left. The PDF on the right is empty where i would expect the static text to be..

    Any ideas what i can do?

  • Profile Image
    candy
    Answered on October 16, 2017 at 04:36 AM

    We're sorry for the inconvenience you have.

    I have cloned your form named "TOOL Request" on my side in order to test it. In order to show static texts on the submission PDF you need to enable "Show Header and Texts" option as you can see the screenshot below:

    1508141419Screen_Shot_2017-10-16_at_11_0

    This way has worked on my end. I have checked the form configurations on your side and I have seen that that option is also working on your side as seen below:

    1508141649Screen Shot 2017-10-16 at 11.1

    When I have downloaded the submission PDF, I have seen that static texts are also appearing on the submission PDF currently as seen below:

    1508142583Screen Shot 2017-10-16 at 11.2

    Our software developers might have fixed the issue you had previously. Or, maybe enabling "Show headers and texts" option did not save in the submission PDF preferences. You need to click gear icon twice in order to save the options you have enabled/disabled.

    I have cleared your form caches in order to avoid any possible issue next time.

    Please check on your side again and let us know if the issue still persists.

  • Profile Image
    greenpest
    Answered on October 17, 2017 at 09:43 PM

    I'm having the same problem.  All of my submissions up until about a week ago worked fine, but now they aren't showing any of the headers or text.  I'

    ve tried unchecking and rechecking the box to include the headers and text, but it's still not working.  Any suggestions for me?
  • Profile Image
    TycenDemolitions
    Answered on October 17, 2017 at 09:59 PM

    Thanks for the suggestions. Following on from the thread above i would like to add that i tried cloning the form and troubleshooting with the clone but the cloned form works fine.

    i can disable and re-enable the "Show headers and texts" option and the changes are reflected in the PDF as desired. the issue is not present in the cloned form only in the original.

  • Profile Image
    candy
    Answered on October 18, 2017 at 03:03 AM

    Dear @TycenDemolitions,

    We are glad to hear that your issue has been fixed.

    Dear @greenpest,

    I have split the thread in order to assist you better. Please follow your answer at the following thread URL: https://www.jotform.com/answers/1275965  

    Thank you.