Form error when Accessed in IIS network

  • Profile Image
    matt2002
    Asked on October 17, 2017 at 06:05 AM

    Hello!

    I have created quite a few forms using JotForm previously without issue, but for some reason I cannot get this one (www.mattjroberts.co.uk) to work, upon submission I am presented with a 405 Verb not allowed error, I have gone into IIS and added POST as an allowed verb, which hasn't rectified the issue. I am alos not using my form to send data through to a custom Thank You page, as I believe this can also sometimes cause the issue. Any ideas...?

     

    To recreate the issue, simply fill in the form, and hit submit.

     

    Thanks,

    Matt

  • Profile Image
    seth
    Answered on October 17, 2017 at 09:42 AM

    Hello,

    The contact form you are using on your website is not a JotForm. Hence, I can't help you with the issue you are having.

    Please embed a JotForm and try again.

    Here is a guide about embedding:

    https://www.jotform.com/help/67-Which-Form-Embed-Code-Should-I-Use


    Please feel free to contact us again.

    Thank you.

  • Profile Image
    matt2002
    Answered on October 17, 2017 at 11:27 AM

    Sorry, was being a muppet and forgot to switch over to my live site, all working now :-)

  • Profile Image
    TREVON
    Answered on October 17, 2017 at 01:16 PM

    I have tested contact us page using the shared link and I could not replicate the issue. The form submitted without any issues. Kindly see illustration below.

    1508260569IIS error.gif

    Below is a support link on how you may need to resolve the issue on IIS as it seems this is a configuration issue on you network server.

    https://www.techrepublic.com/forums/discussions/http-405-verb-not-allowed/

    Hope the information above was helpful. If you need further assistance, kindly feel free to let us know.