What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    Error: Form ID did not match

    Asked by ashdav on September 06, 2012 at 08:57 PM

    Hi,

    I've got a client receiving the error 'Form ID did not match'.
    This is for the form located here.

    I'm not able to replicate the issue on my computer, so I'm really confused. Is there anything wrong with my form?

    Thanks,

    Ash 

    Page URL:
    http://authors.tablo.com.au/premium-submit-54939/

    Screenshot
  • Profile Image

    Answered by fxr on September 06, 2012 at 09:04 PM

    Hi Ash,

    It looks fine to me.

    Have just done a test submission and all looks well.

    Is there is any chance of asking the person who had the problem to try again?

    It may have been an odd and very transient network issue. 

  • Profile Image

    Answered by ashdav on September 06, 2012 at 09:21 PM

    Thanks for your quick response!

    I'll ask the client to try again, and I'll keep testing the form on a few different browsers just to make sure all is good.

    Thanks for your help,

    Ash

  • Profile Image
    JotForm Support

    Answered by liyam on September 06, 2012 at 09:31 PM

    I just made a test and just like you and fxr, I was not able to replicate the problem and saw your thank you page.

    I have removed my submission and your submissions counts was not affected by my test.

    We'll wait for your updates on this matter.

  • Profile Image

    Answered by ashdav on September 07, 2012 at 04:25 AM

    Hi Guys,

    Clearing the browser's cache and cookies seems to have resolved the problem.

    Thanks for your help once again!