Error: Form ID did not match

  • Profile Image
    ashdav
    Asked on September 06, 2012 at 08:57 PM

    Hi,

    I've got a client receiving the error 'Form ID did not match'.
    This is for the form located here.

    I'm not able to replicate the issue on my computer, so I'm really confused. Is there anything wrong with my form?

    Thanks,

    Ash 

  • Profile Image
    fxr
    Answered on September 06, 2012 at 09:04 PM

    Hi Ash,

    It looks fine to me.

    Have just done a test submission and all looks well.

    Is there is any chance of asking the person who had the problem to try again?

    It may have been an odd and very transient network issue. 

  • Profile Image
    ashdav
    Answered on September 06, 2012 at 09:21 PM

    Thanks for your quick response!

    I'll ask the client to try again, and I'll keep testing the form on a few different browsers just to make sure all is good.

    Thanks for your help,

    Ash

  • Profile Image
    liyam
    Answered on September 06, 2012 at 09:31 PM

    I just made a test and just like you and fxr, I was not able to replicate the problem and saw your thank you page.

    I have removed my submission and your submissions counts was not affected by my test.

    We'll wait for your updates on this matter.

  • Profile Image
    ashdav
    Answered on September 07, 2012 at 04:25 AM

    Hi Guys,

    Clearing the browser's cache and cookies seems to have resolved the problem.

    Thanks for your help once again!