New Form Layout/Input Table Element: On mobile, input table skips some questions

  • Profile Image
    mnijboer
    Asked on October 18, 2017 at 01:07 PM

    Dear JotForm,

    Thanks for having made this awesome survey platform!


    Unfortunately,.. I got a little problem could you guys help me out?

    The problem is as folowing:
    Question 23 of survey: https://form.jotformeu.com/72632015113341 is not working properly on (samsung devices) android phones.

    The specific question has 21 'questions within' each with two answer possibilities. (see screenshot..) once a question have been answered, it will randomly skip some questions and let's say continue at question 4 of 21... while question 2 and 3 haven't been answered.

    To clarify: Someone answers the first question (1/21): Klimbos Veenhuizen -> Ja, ken ik: 

    and then presses next, will get a random following question like question (4 of 21) instead of the next question (2/21) and then (3/21) .. etc. they are just randomly being shown?


    I do hope that you understand the problem. It's kind of difficult to explain.. if you need further explanation please let me know :) I hope you have a solution.


    Edit: The same problem occurs when answering this question on preview mode (select the mobile landscape mode version) as shown in the screen shot.

    1508347501Schermafbeelding 2017-10-18 om

  • Profile Image
    Kiran
    Answered on October 18, 2017 at 02:29 PM

    I understand that the form is displaying an unrelated question as when the next button is clicked. Since the form is in a different language, it is taking a while to check the issue. Please allow me some time to check this and get back you.

    Thank you! 


  • Profile Image
    mnijboer
    Answered on October 18, 2017 at 02:38 PM

    Hi Kiran,


    Thanks, I understand. looking forward to your reply!

    .. Indeed, the consecutive question is sometimes randomly skipped for a random one.. (only at question 23)


    Thanks in advance.

  • Profile Image
    david
    Answered on October 18, 2017 at 04:01 PM

    I checked this on my end and so far I have been unable to reproduce the issue.  Each time I progressed through the sub-questions, they were shown in order.  Is there a specific browser used to reproduce this?  So far I have been unable to get any questions to skip.

  • Profile Image
    mnijboer
    Answered on October 19, 2017 at 03:37 AM

    To clarify the problem i've made a short video to show the problem.

    Link: https://youtu.be/inRdzkpdFJg

    This specific problem at question 23 occurs on all android devices and in preview mode of this jotform.

    Thanks in advance!

  • Profile Image
    amy
    Answered on October 19, 2017 at 08:27 AM

    Please accept our apologies. I checked your form and I replicated the issue you have encountered. 

    I am escalating the issue to our developers. You will be informed via this support thread when we fix it.

    Thank you very much for reporting it to us.

  • Profile Image
    mnijboer
    Answered on October 19, 2017 at 08:34 AM

    Thanks for the quick reply and work input for a solution!


    I'll wait for a solution. thanks in advance.

  • Profile Image
    mnijboer
    Answered on October 23, 2017 at 06:36 AM

    Hi Jotform,

    Is there a temporary solution for the meantime?

    I have about 100 respondents waiting for to fill in the survey. Would be great if there is a temporary fix!

    Thanks in advance :)

  • Profile Image
    Kiran
    Answered on October 23, 2017 at 09:41 AM

    We are sorry for the inconvenience this may have caused. Since the questions are added to the input field, unfortunately, there is no temporary fix for this issue unless the user fills the form using a PC.

    A workaround can be adding several Single choice fields to the form after removing the Input table and this may not be feasible for the existing form since the form has already received some submissions. Deleting the field would also remove the submission data of the particular field.

    Let me send a note to our backend to see if there is any progress in this regard. If there is any news, we'll update you here.

    Thank you! 

  • Profile Image
    ceren
    Answered on October 24, 2017 at 10:26 AM

    Hello mnijboer,

    We're sorry for the inconveniences. Mobile layout issue of Input Table field is fixed. I've checked your form and it seems everything is working as expected now.

    Thank you for contacting us.

    If you have any other questions please let us know.