Stripe payment not working

  • Profile Image
    atlasone
    Asked on October 18, 2017 at 08:02 PM

    Username is  atlasone: I have built a form Credit Card payment using my Stripe account and I also activated it when building the form.

    The form will not function. When I put my credit card details in it rejects them saying ERROR.

    I have contacted Stripe but they email that I should contact you. Can you advise why it isn't working?

    This has now become urgent.

    Regards Mike Bartlett

    Hi Michael,

    Jazel here, thanks for taking the time to reach out to us--I'm happy to work our your integration issue. Jotform is a platform that uses our API and they have their own walkthrough[1]. I would reach out to them[2] and have them find a resolution for you. Also, if you are running test charges, please make sure you are using cards from our testing page[3]. Live cards won't work.

    I hope you found this information useful. Of course, if you have any other questions, feel free to send them along.

    Cheers,
    Jazel

  • Profile Image
    John_Benson
    Answered on October 18, 2017 at 10:48 PM

    I checked your Stripe Integration and it is configured properly. May I know what Error message you're getting so we can investigate it further?

    We'll wait for your response. Thank you.

  • Profile Image
    atlasone
    Answered on October 20, 2017 at 11:43 PM
    I finally got it to work. Your instructions are poor.

    I also need to get a conformation number sent to us as it has to relate to a payment so that it can be allocated to the right department.


    Regards
    Mike Bartlett

    ...
  • Profile Image
    Chriistian
    Answered on October 21, 2017 at 04:23 AM

    Since the issue about the Stripe error on your form has already been solved, I have moved your next question about the confirmation number on Stripe to a separate thread. You can find it here: https://www.jotform.com/answers/1279059.