Date Picker - Condition 'Is Empty' not working

  • Profile Image
    JakobOHG
    Asked on October 20, 2017 at 07:39 AM

    I added the condition 'if date picker is empty then show something' but it does not work.

  • Profile Image
    BDAVID
    Answered on October 20, 2017 at 10:42 AM

    Is this the form you are referring to? http://www.jotformeu.com/form/72902073892359 

    I could not find any condition that would show another field if the date field is empty. You may provide a screenshot to illustrate what you mean: https://www.jotform.com/help/438-How-to-Post-Screenshots-to-Our-Support-Forum 

  • Profile Image
    Rose
    Answered on October 23, 2017 at 08:32 AM

    I checked aforementioned form both through its original URL and on a cloned version of it. Both of them work as expected. 

    You set following condition for empty date field and the form shows red circle when the date field is empty.

    1508761882Screen Shot 2017-10-23 at 15.3

    1508761896Screen Shot 2017-10-23 at 15.3

    You set following condition for non-empty date field and the form shows green circle when the date field is filled.

    1508761915Screen Shot 2017-10-23 at 15.3

    1508761926Screen Shot 2017-10-23 at 15.3

    Could you please elaborate the issue you are having? Because, I wasn't able to replicate it on my end. 

  • Profile Image
    JakobOHG
    Answered on October 23, 2017 at 08:41 AM

    1) Date empty -> red

    15087622841.PNG

    2) Date filled -> green

    15087623242.PNG

    3) Date removed -> still green

    15087624053.PNG

  • Profile Image
    Rose
    Answered on October 23, 2017 at 10:26 AM

    We are sorry for this inconvenience. 

    I was able to replicate the same problem when I delete the input of date field. Deleting input of date field does not trigger the related condition if the date field is set to lite mode. I'm reporting this problem to our developers. Once the problem is fixed, you will be notified via this thread.

    On the other hand, if you disable lite mode, the problem will be fixed. Here is the screencast of it:

    15087685682.gif

  • Profile Image
    Scott
    Answered on November 03, 2017 at 06:59 AM

    Hey everyone,

    This issue is now resolved. For the lite mode, if the input is empty the conditions are now working as expected.