Hi, my form does not seem to work on some browsers and doesn't work with apple ipad or iphone

  • Profile Image
    year6leavers
    Asked on September 07, 2012 at 05:20 PM

    I'm having a lot of queries for a malfunctioning form from customers that I can't answer?

    There is an issue where the back and next button are showing simultaneously on some devices/browsers (I am told!)

    Plus despite all fields being 'required', customers are managing to send half of the form in to me, without getting to the paypal payment screen, even though every part of the form is required so this shouldn't be possible -

    they manage to get to the thank you screen and they haven't paid :S

    I have had customers who the form has worked fine for, and I have tested in IE9, chrome and safari and it works fine for me :S

    Help!

    Thank youuuu

  • Profile Image
    EduardoMendez
    Answered on September 07, 2012 at 06:47 PM

    Hello @year6leavers 

    I looked at your page and it seems that you have embeded the form using the java script code.  A good suggestion would be to use the iFrame embeding code in order to avoid any conflicts on your page.  You can find the iFrame code here.

    Let me know if  you have any other issues after implementing this suggestion!

  • Profile Image
    year6leavers
    Answered on September 08, 2012 at 03:04 AM

    Hi

    Thank you!

    I've swapped the script over for an iFrame and it seems to be working on my iPhone now, so I imagine it will work fine for those who want to use an iPad to buy.

    I'll keep an eye on any further problems, or the abnormality where people were managing to bypass the payment screen :S  it's only 8am here so I will see what the day brings and let you know :)

    (Not an urgent question, but when I embedded the iFrame, it seems have made my page verrrry long! - do you know what might have caused this? - it's not critically important, just cosmetic :)

    Thanks again!

  • Profile Image
    NeilVicente
    Answered on September 08, 2012 at 06:14 AM

    @year6leavers

    Try decreasing the height property of the iFrame in your embed code. It is currently at 711px.

    Use the codes below for example:

    <iframe scrolling="no" frameborder="0" style="width: 100%; border: medium none; height: 430px;" src="//form.jotformeu.com/form/22432796806359" allowtransparency="true">
    </iframe>

    Hope this helps!