Take photo or Image uploader

  • Profile Image
    SLCHTransportTeam
    Asked on October 24, 2017 at 07:07 AM

    Hello,

        I am having issues with both the Take Photo widget and the Image Uploader widget.  I have added each one separately to my 'MICU Maintenance " form successfully.  I am able to take a picture or upload a previously taken picture.  But in all instances, I am not able to submit any photo.  Each time I hit "submit", I am just taken back to the top of the form.  On every occasion, the image was in the document, I just am not able to submit.  I have temporarily removed the photo option so as to not generate confusion for the users.


    Thank you.


  • Profile Image
    John_Benson
    Answered on October 24, 2017 at 10:44 AM

    I cloned your form to test it on my end. I added the Take Photo widget and it is working properly. Here's the screen capture of the clone test form:

    1508855606tesddfcam.gif

    Here's the demo form link: https://form.jotform.com/72964426128967

    You can test it or you can clone it if you want. To clone the form, please follow this guide: https://www.jotform.com/help/42-How-to-Clone-an-Existing-Form-from-a-URL

    May I know if the form is embedded into a website? If yes, please share the website URL and try to add the Take Photo widget so we can further check it. 

    I hope this helps. If you need further assistance, please let us know.


  • Profile Image
    SLCHTransportTeam
    Answered on October 27, 2017 at 05:24 PM

    Thank you for the update John.  The widget is working great when using a laptop, but the end user will most likely be using an i-phone or Android device to add a photo to the form.  The end user accesses the form through my app.  The widget will allow a photo to be added without issue, but when attempting to submit, the screen just shows the top of the form again and does not allow for the form to submit.


    Thank you.

    Brian

  • Profile Image
    jonathan
    Answered on October 27, 2017 at 07:15 PM

    Brian,

    I also test submitted using John's form https://form.jotform.com/72964426128967 on mobile browser but I could not reproduce the problem. The form submitted successfully with Take Photo widget taken.

    1509146005zzz 2017-10-28 07.11.55.png


    The end user accesses the form through my app. 

    Can you also share to us the URL of your app where your form was used? We can also test it within your app to identify the problem.

    Let us know if issue persist.


  • Profile Image
    BDAVID
    Answered on November 02, 2017 at 03:32 PM

    What's the name of the app, or how can we find it? I see you have provided access to the BuildFire site, which is used to create the App, I don't want to edit or touch anything that could ruin what you have there. 

    Also, please try embedding your form using the Iframe code: https://www.jotform.com/help/148-Getting-the-Form-iFrame-Code 

    Before you embed the code, paste it in a text editor like WordPad, you will notice two part of codes, only copy and embed the Iframe part in your webpage, example:

    Make sure to set the scrolling property to "yes", example:

    1437426072scrolling.png

  • Profile Image
    SLCHTransportTeam
    Answered on November 02, 2017 at 03:36 PM

    Thank you for your response.  The app is called "KidsFlight".  It is in both Apple and Android.


    Brian

  • Profile Image
    SLCHTransportTeam
    Answered on November 02, 2017 at 03:49 PM

    Success!! It is working. Thank you.