Submission button not working

  • Profile Image
    TinyDinos
    Asked on October 24, 2017 at 09:24 AM

    Hi, the submission button is not working and this is affecting my business.

    Several of our students have complained about not being able to register through our online registration form. The form is integrated with Stripe. I've tried the form both embedded in a shell and on its own with the same result. When you click the "Submit" button, the form doesn't submit. It just sits. I've tried in both Chrome and Safari. 

     

    We offer several products to choose from in the stripe integration module and one of them is 'free'. When selected, the form goes through and submission can be completed. For all the other products that require a payment, the submission button does work.

    Please fix it asap,

    Thanks,

    https://form.jotform.me/72879388725477

  • Profile Image
    TinyDinos
    Answered on October 24, 2017 at 09:41 AM
  • Profile Image
    John_Benson
    Answered on October 24, 2017 at 12:11 PM

    Are you receiving an error message? If yes, please provide it so we can check it. To post a screenshot here in JotForm, please follow this guide: https://www.jotform.com/help/438-How-to-Post-Screenshots-to-Our-Support-Forum

    If not, are you stuck on the "Please wait" button after clicking the Submit button? Also, can you please provide the website where the form is embedded so we can check it further?

    We'll wait for your reply. Thank you.