Jotform and stripe integration issue

  • Profile Image
    TinyDinos
    Asked on October 24, 2017 at 10:14 AM

    Hi, the submission button is not working and this is affecting my business.

    Several of our students have complained about not being able to register through our online registration form. The form is integrated with Stripe. I've tried the form both embedded in a shell and on its own with the same result. When you click the "Submit" button, the form doesn't submit. It just sits. I've tried in both Chrome and Safari. 


    We offer several products to choose from in the stripe integration module and one of them is 'free'. When selected, the form goes through and submission can be completed. For all the other products that require a payment, the submission button does work.

    Please fix it asap,

    Thanks,

    https://form.jotform.me/72879388725477

  • Profile Image
    BJoanna
    Answered on October 24, 2017 at 12:25 PM

    I was not able to replicate mentioned issue. I cannot submit the form because I used the test credit card numbers and the form did not accept it. 

    1508861754stripe1.gif

    I am also not able to replicate the issue on my cloned form that has Stripe set to the Test Mode.

    Here is my clone form: https://form.jotform.com/72965006402957 

    You can use the test credit card number: 4242424242424242

    Are your users still unable to submit your form? Are they using a valid credit card? 

    If this issue can only be replicated on your embedded form, provide us the webpage URL.