Google Integration not creating a folder based on my criteria

  • Profile Image
    atmpalliard
    Asked on October 25, 2017 at 01:59 AM

    I've been using the google integration for years now, but changed my google password, and I've broken it somehow. I removed the integration 5 times now, and tested, all with the right password and login, but it is not creating a folder based on the criteria I enter. 

  • Profile Image
    liyam
    Answered on October 25, 2017 at 04:17 AM

    Hello,

    As we do not wish to remove your existing integration settings, it would be great if you can provide us details on what you would like to achieve or give us details of your previous settings which you are not able to set now.

    We look forward to your response.

  • Profile Image
    atmpalliard
    Answered on October 25, 2017 at 09:27 AM

    I already removed them 5 times, it wasn't working. I just need a folder to be created, off a few fields in the form. The street name, and then the street address, then the due date is what I was using. But I tried just Street name, and it doesn't create a folder. 

  • Profile Image
    TREVON
    Answered on October 25, 2017 at 11:24 AM

    I have cloned your form tested it and I could not replicate the issue. I was able to create folders based on the criteria you shared. I also added Dropbox integration to simulate your setup and could not replicate the issue again.

    1508944988Test Google drive Integration.

    I would like to know if its this form alone that has the issue, would you kindly clone the form and try setting up integration on the cloned form them let us know if it works on the cloned form or not?

    Thank you for your patience and apologies for any inconveniences this may have caused. Will be awaiting your response on the above.

     

  • Profile Image
    atmpalliard
    Answered on October 25, 2017 at 11:50 AM

    Thanks! I did the exact same thing you did in the video, but no new folder was created. I tried just doing a simpler option of just the street, no new folder created. 

    I tried your suggestion of cloning the form, and it makes a new "clone of atm.." folder, but no new folders are created. I tried cloning that form and integrating again, and again it will make the "chlone of clone..." folder but not any subfolder with any form information in it. Definitely odd. If you're doing testing, please don't select a title company, put NONE, it sends copies to them and wastes their time. 

  • Profile Image
    atmpalliard
    Answered on October 25, 2017 at 12:04 PM

    i kept entering from the first form instead of actually typing on the clone. When I entered from the clone it does work fine. So my original form can't be fixed? I have 1600 entries from it, and my website directs to it. 

  • Profile Image
    TREVON
    Answered on October 25, 2017 at 01:49 PM

    Thank you for your quick response and apologies for any inconveniences this may have caused.

    The reason I asked for that test was to confirm if the error was affecting only that specific form or it was affecting your account.

    Now that we know that it is only affecting this form I would like to kindly forward the issue to our Level2 support team, you will be notified via this thread when the issue is fixed.

    Once again apologies for any inconveniences this may have caused.


  • Profile Image
    asil
    Answered on October 26, 2017 at 07:01 AM

    I have checked logs for your form with ID "41008251772145". Logs show that your form did not get necessary token from Google(error message="invalid_grant"). I have researched this error and there are two common causes for this. Either you may have changed your Google password or you may have revoked our access to Google Drive. Google stops sending authorization tokens when user changes her/his Google password for protection.

    Can you check your Drive settings (Upper right gear icon -> Settings -> Manage Apps) and look for Jotform. If it is there, can you disconnect it and try again?

    Thank you.

  • Profile Image
    atmpalliard
    Answered on October 26, 2017 at 05:40 PM

    Got it. I tried that, removed the integration. CHecked google drive permissions, removed those. made the integration again and still didn't work. I just linked to a different google account and it's fine. I'll just go with that. Thanks for all the help!

  • Profile Image
    liyam
    Answered on October 26, 2017 at 09:30 PM

    Thanks for letting us know of your alternative solution. Feel free to let us know again anytime if you have questions.

    All the best.