What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    Email alerts not sending to recipient email address

    Asked by carlbanks on September 10, 2012 at 08:04 AM

    I have a problem with email alerts where if i send a test notification email it will go to the email address which is set up in the account settings instead of the recipient email address. 

    I've tried various suggestions previously mentioned on other threads but to no avail. 

    Please can someone help!

     

    Thanks

    Carl

     

    Page URL:
    http://www.jotform.com/?formID=22482784702356

    Screenshot
  • Profile Image
    JotForm Support

    Answered by EduardoMendez on September 10, 2012 at 09:35 AM

    @carlbank,

    I have tried to reproduce the problem without success.  When I change the recipient e-mail, the notification is sent to the updated address.  Please try deleting the notification and creating a new notification to see if that helps.  Let us know if that fixed the issue!

  • Profile Image

    Answered by carlbanks on September 10, 2012 at 10:25 AM

    I have tried deleting the notification and creating a new one yet it still sends the alert to the account holder email - not the recipient email address. I really can't work it out!

  • Profile Image

    Answered by pinoytech on September 10, 2012 at 12:12 PM

    Hi Carl,

    Have you tried already deleting your browser cache and cookies after creating a new notification? If not, please give a try.

    Thank you!

  • Profile Image

    Answered by carlbanks on September 11, 2012 at 09:55 AM

    Thanks - I've just tried that and it still doesn't work. No matter what email address I put as the recipient it will just send it to the account holder's email. 

    I realy don't understand, it should just work!! Arrgghh

    Please offer any other suggestions

    Regards

  • Profile Image

    Answered by AtacanC on September 11, 2012 at 11:10 AM

    @carlbanks

    Carl, as far as i know, if you hit the Test Email button system will send the test email to account holder's email address. It has been changed to prevent spam. May i suggest you to do the test on your actual form? We can delete the submission from your count.

    Please do let us know after you have done your test.

  • Profile Image

    Answered by carlbanks on September 12, 2012 at 05:09 AM

    Aha! That seems to have done it. Before I was always using the test email and getting the same response. I never actually tried it on the actual form.

     

    Thanks for your quick and effective response on this.

     

  • Profile Image
    JotForm Support

    Answered by jonathan on September 12, 2012 at 05:52 AM

    @Carl

    To clarify, the Test button in the email notification will always send it to the JotForm account holder.

    The actual form, when submitted in actual, will then send the email to the email address in the Recipient E-mail box.

    We are glad to know that this is all sorted now. 

    Thank you for using our service.

  • Profile Image

    Answered by josecanelas on September 18, 2012 at 05:14 PM

    This is not working for me. 

    I have setup a different email in the recipent email and directly in the website its me that always get the subsmission, not the email that i have add it. 

     

  • Profile Image

    Answered by ekonomical on September 18, 2012 at 05:37 PM

    I am having exactly the same issue from the live form as well

  • Profile Image

    Answered by fxr on September 18, 2012 at 06:32 PM

    @josecanelas,

    Please open a new thread for your issue and provide a link or the name of your form and we will take a look into what may be going wrong on your form.

    Thanks!