Language tool disappeared on the form

  • Profile Image
    ayadov77
    Asked on October 29, 2017 at 02:09 PM

    Hi and thanks in advance for your help,

    I disabled my form for 3 days and now after I enabled the form again the Translations (English - Dutch)  disappeared.

    I still can see Translations from the edit mode but is not shown when published.

    https://form.jotform.com/ayadov77/schipholtaxibookingform

      can you please help.


  • Profile Image
    jonathan
    Answered on October 29, 2017 at 02:29 PM

    I was able to reproduced the issue as well. Even though my test form have language tool enabled, I could not see language option tool in the preview/live form.

    1509301776zzz 2017-10-30 02.24.38.png

    Please allow me some more time to investigate what could be causing this issue. I'll be back shortly.

  • Profile Image
    jonathan
    Answered on October 29, 2017 at 03:32 PM

    I found that the issue was due to the combination of the following.

    #1 Dirty Conditions. There were multiple conditions that have error on them due to deleted fields. I suggest you clean the Conditions by fixing or removing/deleting those condition statements that have error on them.

    1509305304zzz 2017-10-30 03.03.12.png


    #2 The Get Form URL widget have issue and was causing the language tool to not work. You can remove this on the form.

    1509305372zzz 2017-10-30 03.22.17.png


    You can check my test form here https://www.jotform.com/73015473937965

    The language tool is working on the form when I fix those 2 issues on the form.

    Let us know if this did not work for you.



  • Profile Image
    ayadov77
    Answered on October 29, 2017 at 03:44 PM

    it worked, Thank you very much for your excellent help.



  • Profile Image
    jonathan
    Answered on October 29, 2017 at 03:59 PM

    Thank you for updating us on the status and letting us know it is working now.

    Contact us anytime should you need our assistance again.