How can I remove labels from certain fields?

  • Profile Image
    ajkreiss
    Asked on January 31, 2011 at 11:36 AM

    I am working on a form that requires a list.  I want each item on that list to have its own field, so that I control how I receive that information.  I have gone through and deleted text, which brings the boxes closer together, and is exactly how I want it.  But, if I leave the page and then return later, the 'click to edit' text has reappeared.  How can I get rid of it, and make it stay gone?

  • Profile Image
    aytekin
    Answered on February 01, 2011 at 07:34 AM

    You should probably have labels but hide them using Inject Custom CSS feature. 

    I have done one for you, you can do the same for other fields as well.

    1. Find out the label ID for that field:

    2. Click on "Preferences" button and then enter an entry like this for each label like this:

    #label_27 { visibility:hidden; }

  • Profile Image
    ajkreiss
    Answered on February 07, 2011 at 11:28 AM

    I have followed these instructions for my form, and in the editing screen it appears to be working.  However, in the preview and after I paste the code into my site, the labels reappear- mostly as "...", and one as "click to edit".
    Do I need to format my Custom CSS in a particular way?  Is there another step that I am missing?
  • Profile Image
    ajkreiss
    Answered on February 07, 2011 at 11:41 AM

    I have followed these instructions for my form, and in the editing screen it appears to be working.  However, in the preview and after I paste the code into my site, the labels reappear- mostly as "...", and one as "click to edit".
    Do I need to format my Custom CSS in a particular way?  Is there another step that I am missing?
  • Profile Image
    aytekin
    Answered on February 08, 2011 at 03:40 AM

    First of all. Do not have the labels empty. Have some labels. You will need them when you receive emails about user responses and you will need them when you create and download a report on JotForm. 

    My guess is that you did not find the correct label IDs and added them to the Preferences as I shown above. Just add one label at a time and then test the form and see it become invisible. Do it one at a time. This way you can find out what is going on.

  • Profile Image
    jane923
    Answered on April 01, 2011 at 05:52 AM

    why some information that i creat on the form is missing when i was preview it

  • Profile Image
    allanftd
    Answered on April 01, 2011 at 06:39 AM

    Hi jane923,

    Thank you for your message. Kindly provide more information about your concern so that we can assist you further.

    Thank you for using JotForm!

    JOTFORM SUPPORT