WP oEmbed: Error when submitting form, "allow-forms" permission is not set

  • Profile Image
    anaheimbeautiful
    Asked on November 09, 2017 at 02:31 PM

    I have embedded my form with the link shown on the jotform.com website into a wordpress page and although the form appears - when I press submit or go to payment, it just gives me a "please wait" prompt.  

    We tried the link that was sent to us via email - see screenshot, but it doesn't work with word press.  This form worked fine for our last event which was in September. 



  • Profile Image
    EltonCris
    Answered on November 09, 2017 at 03:24 PM

     You're not using an iframe embed code as of checking.

    Here's the error when submitting your embedded form.

    Your WP page has set limitations on embedded forms by putting it into sandbox mode without a proper flag to the sandbox attribute’s value. Based on the error, it requires "allow-forms" not just "allow-scripts" in the sandbox attribute.

    For now, we suggest using an iframe embed code. This should work.

    Here's how:

    1. Get your iframe embed code http://www.jotform.com/help/148-Getting-the-Form-iFrame-Code

    2. Paste the iframe embed code into your WP post/page under Text tab.

    Example:

    I have also forwarded this to our developers so they can apply a permanent fix if there's any. Thanks

  • Profile Image
    burak
    Answered on November 30, 2017 at 04:13 AM

    Hello anaheimbeautiful,

    Can you re-embed your form by using our WordPress plugin. I think your problem should've been fixed now.