Hover Text of a particular field not translating to Italian

  • Profile Image
    Dark_Jot
    Asked on November 12, 2017 at 06:53 AM

    Hi,

    I'm using English to Italian translation on some forms, but on one in particular the Italian translation remains in English.

    It's on the 'Rate the Portal' form, under 'Knowledge Base Search' - ironically!

    Do you have any ideas?

  • Profile Image
    Mike_G
    Answered on November 12, 2017 at 10:35 AM

    We would like to apologize for any inconvenience this is causing you. I was able to reproduce the issue but I'm glad to inform you that I was also able to find where the issue is and was able to fix it.

    I understand that only the hover text of the "KNOWLEDGE BASE" Scale Rating Field is not translating to Italian in your form.

    It seems that for some reason, the translation for that field won't work if the texts and its translation are just copied as a whole (copy then paste). May I suggest that you type the original (English) hover text for that field and its translation (Italian) manually, please?

    That worked for me when I tried it on a clone version of your form — https://form.jotform.com/73153992473969

    Please feel free to contact us again anytime if you have questions or concerns.

  • Profile Image
    Dark_Jot
    Answered on November 12, 2017 at 05:43 PM
    Hi Mike,
    I'm not even sure I understand what you've said. I've tried typing all your suggestions, but cannot get Italian to appear as an end-result.
    I've re-typed the whole of the hover text in the form, then gone and typed in manually the Italian translation to the form's Settings, and get English in both languages.
    Just also noticed this problem exists in a couple of other forms, one of which is the 'Contact Us - English, Italian and Chinese'. It occurs in both Italian and Chinese.
    Please let me know again what fields get what text and in what languages.
    Best regards,
    ________________________________
    ...
  • Profile Image
    Jim_R
    Answered on November 12, 2017 at 06:19 PM

    I think what my colleague was trying to say is that, instead of copying/pasting the Hover Text, you should manually type them in for them to be translated properly. Perhaps there were extra, unnecessary formatted characters that were included when you pasted them, thus causing the translation to fail. Here's what I mean:

    Mike will be able to correct me if I'm wrong with my assumption so for the time being, please give his suggestions a try to see if that will help.