Other field value is not being passed to another field in the same form using conditions

  • Profile Image
    renag
    Asked on November 14, 2017 at 11:46 AM
    unfortunately, it still doesn’t work properly
    as you can see in the attached
  • Profile Image
    Mike_G
    Answered on November 14, 2017 at 12:43 PM

    I would like to apologize, however, the attachment (screenshot) you tried to share with us was not posted for some reasons. Perhaps you are trying to reply via your email. To post screenshot in the support forum, please refer to this guide — How-to-Post-Screenshots-to-Our-Support-Forum

    With regards to your concern, I have tested your form — http://www.jotform.me/form/72342756910457 and although the issue with using the "other" option in conditions was already fixed in your other thread — https://www.jotform.com/answers/1285557, it seems that the value entered on the "other" option is not being passed another field (number) in your form.

    I was able to reproduce the issue with a clone version of your form — https://form.jotform.com/73175188308967

    even after I have updated the conditions from these:

    1510680183t12_22_48.png

    to this:

    1510680242t12_23_37.png

    Even if that is the case with your form, I can't seem to replicate it with a new form that has the same logic — https://form.jotform.com/73175042508958

    1510680644t12_30.gif

    Note: I did not set calculation values with the radio button field in that test form since the amount (value) is part of the option labels and we are passing it to a number field where "texts" are ignored.

    I have forwarded this to our developers so it can be further checked. Although we cannot provide any timeframe for when this will be fixed, please be assured that once there is an update from our development team, we will notify you in this thread right away.

  • Profile Image
    renag
    Answered on November 19, 2017 at 10:43 AM
    that's fantastic!
    ...
  • Profile Image
    Helen
    Answered on November 27, 2017 at 02:18 AM

    Hello @renag,

    Thank you for reporting this issue.

    It has been fixed now. Please try it again and if you have any questions or issue please do not hesitate to contact us.

    Thanks.