Show/hide fields not working based on previous field's answer

  • Profile Image
    swhitw
    Asked on November 17, 2017 at 10:46 AM

    Hi,

    I'm building a form where I need to show/hide fields based on selection. https://form.jotformeu.com/73193867776374

    The first three conditions work OK but when selecting No for New Resident it should hide 1 field and show 2 additional fields, but it won't whatever way I try. Can you help with where I'm going wrong please?

    Thanks,

    Simon

  • Profile Image
    aubreybourke
    Answered on November 17, 2017 at 12:16 PM

    I have cloned your form and tested it. I could reproduce the problem. When selecting no for "are you a new resident" nothing displays.

    I'm not sure why its not working. I assume it could be a bug. So I will escalate the issue to Level 2 support. They will look into the problem and post a response on this thread.



  • Profile Image
    EltonCris
    Answered on November 19, 2017 at 03:26 PM

     Let me please clarify that there was no bug. It is just a natural reaction when a condition conflicts with one another.

    Here's how to fix the condition problem in your form.

    1. First, remove the following fields in your "Do you currently..." Is Empty condition. Having these fields in this particular condition will force the fields to display whenever the "Do you currently..." field is filled.

    2. Then you only need the following conditions for them to work.


    Here's my demo form: https://form.jotform.com/73225888870974

    You can clone this form if you want so you can use it as well as see the changes made. Guide: http://www.jotform.com/help/28-Cloning-a-Form-from-a-Web-Page

    If I have missed something here, let us know.