Required fields do not work, checkbox not saving to database....

  • Profile Image
    paulturks
    Asked on February 02, 2011 at 09:26 PM

    I see others have had this issue recently but we have the following issues on all browsers.

    1. Required fields - these are not working

    2. Data capture - we have check boxes on the form, the table has been created in the backend but the yes/no is not being captured so all fields are blank regardless of whether they are checked or not

    3. additional fields added to form - we create checkbox on form, remove additional fields, save and then display form and previously removed checkboxes are stil there.

    Here is the form

    http://www.jotform.com/form/10263818627


    Help please I have a facebook campaign starting shortly and i need to embed this form

  • Profile Image
    aytekin
    Answered on February 03, 2011 at 05:00 AM

    Tested the form and I do not encounter same problems when I complete this form:

    http://www.jotform.com/form/10263818627

     

    1. Required fields work fine. I was asked to enter all questions.

    2.I looked at the Submissions page and all of fields I entered showed up fine there. Including checkboxes.

    In case, you were having this problem on your email, I reset your emails.

    3. Every time you change your form code, you must update the code on your Facebook site.

    Are you using that URL to test your form, or are you encountering these problem on your facebook page? If you are encountering these problems on Facebook you must provide the URL so we can take a look.

    I think your problem was that you were not updating the facebook code after making changes on your form.

    You must update the code on your facebook page every time you edit your form on form builder!

  • Profile Image
    paulturks
    Answered on February 03, 2011 at 06:11 PM

    Hi. The issue occurs on Facebook but there also appears to be a bug in the form builder, I add a checkbox and 3 checkbox options are automatically available, I delete 2, save, the form looks correct but when I preview and grab the link provided (which is below) all 3 checkboxes are back again??

    Below is the jotform preview code and the facebook page where its being tested. You will notice that we had to remove the additional checkboxes before using with facebook. Once in facebook the form loses its formatting and the required fields do not work.

    http://www.jotform.com/form/10263818627

    http://www.facebook.com/pages/Spreadit/194124175392?v=app_4949752878

  • Profile Image
    aytekin
    Answered on February 04, 2011 at 06:03 AM

    If you have trouble modifying the checkbox options on the form builder, instead click on "Options" button on the toolbar. You will see the Options button only when you have the checkbox question selected. You can enter a list of all options in that box. 

  • Profile Image
    Jack Devine
    Answered on June 13, 2011 at 04:23 AM

    Im having this problem of getting fields required in a form on a database - This is urgently needed

  • Profile Image
    liyam
    Answered on June 13, 2011 at 10:52 AM

    Hello Jack,

    Can you provide us more details about your problem?  It would be great if you can tell us the name / ID of your form, and your proper username so for us to be able to look into your issue.

    Thanks,

    Liyam