Why my forms are not showing properly?

  • Profile Image
    aak8
    Asked on November 27, 2017 at 11:40 AM

    Hello,

    The forms in our account (comm@aak8.org) are currently not allowing people to submit -- the button doesn't work. This is has been going on for over a week!

    Strangely, I am unable to duplicate the problem on my laptop or phone, but my assistant who uses the same browser (Firefox -- same version) and the exact same phone (Safari on iPhone7 plus) is having the problem. And in fact, the JotForm web pages won't upload for her entirely -- it appears that the CSS is not loading and no links aren't working on the admin side. She can't even log in.

    This morning when I came in, I was logged in already but like my assistant, the web page wouldn't fully load. After a few minutes of doing other things, I tried to go to the JotForm admin page and it did load as usual. My assistant still can't get in and the page still will not load for her.

    Most importantly, we use JotForm for a LOT of internal and external form and data collection on a daily basis, and currently many people are having trouble with the forms!!!! Please help -- this is URGENT!!

    Thank you for your quick response,

    Trish Cummings

    Communications Manager

    American Academy

  • Profile Image
    Chriistian
    Answered on November 27, 2017 at 12:05 PM

    I believe I have responded to your colleague in https://www.jotform.com/answers/1307832. Please check the thread and give us more information.

  • Profile Image
    aak8
    Answered on November 27, 2017 at 02:19 PM

    Hi Chriistian,

    Sorry. We are both working to resolve this for our staff (300 people) and parents (3000 people) as quickly as possible.

    We are experiencing two sets of problems. I'm not sure it they are related but it's new as of about two weeks ago.

    We are working with our own IT department and your white pages info to be sure our firewall isn't doing something goofy. However, please note that the problem persists even off campus/off network.

    1) ADMIN:

    I am able to log in to our account, but my assistant still cannot. She has tried multiple browsers (Firefox, Chrome) and is working with the latest versions of each. She has cleared her cache and opened and closed the browsers. None of this has worked. We are sitting across the room from each other on the same company network and I can log in, and she cannot. She goes to the jotform.com landing page, which looks fine and normal, but when she tries to select the login link at the top of the page, it's not live/doesn't go anywhere/won't click. When she uses the browser bookmark to get to the jotform admin page (the page that says that you don't have any forms yet because you are not logged in), the page comes over as JUST RAW TEXT, as shown in the clip she sent you earlier. It's like ALL of the backend CSS styles won't load, including link info.

    2) END-USER

    All of our JotForms were working just fine for everyone (we could both log in to the account and the end users were all able to submit for each form) until about a week ago. Now we are having constant problems loading and using the forms (though some can use them just fine, most people are having trouble).

    The problem that people are suddenly running into is that the forms appear to have lost some of their CSS styles. Though the forms almost (but not quite) normal, the functionality has been suspended -- they can't choose dates from pop-up, submit button won't work. As for appearing ALMOST normal, for form field sub text is appearing next to the form fields, and weird bullets are appearing to the side of each form entry, and the background color disappears on some people's windows. I have another clip of what that's looking like:

    NOT NORMAL:

    NORMAL (what the form should look like):


    Do you have any suggestions for what could be causing this? We are desperate!

    Thank you.

    Trish

  • Profile Image
    aak8
    Answered on November 27, 2017 at 02:22 PM

    Sorry -- looks like those clips didn't go through before. Here they are again:


    NOT NORMAL:

    1511810415JotForm Clip.PNG

    NORMAL (what the form should look like):

    1511810520JotForm_NORMAL.JPG


  • Profile Image
    Nik_C
    Answered on November 27, 2017 at 03:43 PM

    I read your entire post, and the issue must be related to network or specific device, especially because we are not able to replicate it. Also according to the screenshot you shared, it looks like a network issue, specifically proxy or DNS settings. 

    There is a simple test you can conduct, please try accessing my forms section or the form you provided from any other network, even mobile 4G would work, so you can rule out the cause.

    Please try and let us know how it worked.

    Thank you!

  • Profile Image
    aak8
    Answered on November 27, 2017 at 06:04 PM

    Thanks for your quick response. Had my IT department working on this simultaneously and they came to the same conclusion at about the same time as you, it seems. Though the behavior wasn't consistent on and off the network, they determined it was a filter on our end. It's been fixed and all seems to be working smoothly. Thank heavens! :) Thank you again for your assistance!