Flash on top of Feedback Form

  • Profile Image
    Samer Mina
    Asked on September 17, 2012 at 06:45 PM

    I am having a problem with the feedback form showing below Flash in IE8. I've added the WMODE=Transparent to the object tag (see below) but it's still not working in IE8.

    Here is the website: www.watertownstorageservices.com

    Thoughts?

     

          <object classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000" codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=9,0,28,0" width="900" height="620">

            <param name="movie" value="wtm_main2.swf" />

            <param name="quality" value="high" />

            <param name="wmode" value="transparent" />

            <embed src="wtm_main2.swf" width="900" type="application/x-shockwave-flash" height="620" quality="high" pluginspage="http://www.adobe.com/shockwave/download/download.cgi?P1_Prod_Version=ShockwaveFlash" wmode="transparent"></embed>

          </object>

  • Profile Image
    abajan
    Answered on September 17, 2012 at 09:39 PM

    From what I can tell, the current source of your page has opaque and not transparent as the value for wmode. Nevertheless, a search of the internet revealed that there are indeed issues in IE8 when using Flash. Apparently, a solution is provided here but I'll need to read up a bit on this and get back to you. In the meantime, my colleagues may well have solutions for you.

  • Profile Image
    idarktech
    Answered on September 17, 2012 at 09:45 PM

    In addition to abajan, try updating your flash script with this:

    <script type="text/javascript">

    AC_FL_RunContent( 'codebase','http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=9,0,28,0','width','900','height','620','src','wtm_main2','quality','high','pluginspage','http://www.adobe.com/shockwave/download/download.cgi?P1_Prod_Version=ShockwaveFlash','movie','wtm_main2', 'wmode', 'opaque' ); //end AC code

    </script>

    Let us know if this doesn't help. Thanks!