Trouble with posting values via API

  • Profile Image
    kristiaansheedy
    Asked on November 28, 2017 at 05:16 PM

    So I've tried the following with name:


    'qid': {'first': 'FIRST', 'last':'LAST'}

    'qid': 'FIRST LAST'

    'qid': ['FIRST', 'LAST'] 

    all to no avail. 


    Have tried the following on multiple choice: 

    where options = 0|1|2

    'qid' : [0,1,2]

    'qid' : ['0', '1','2'] 

    'qid' : '0,1,2'

    'qid': '0|1|2'

    'qid': {'0': 1, '1': 1 , '2': 1} 

    to no avail as well. 

    Can has helpz? 

    Thanks XD 


  • Profile Image
    Jan
    Answered on November 28, 2017 at 08:25 PM

    The normal format for the multiple choice field is:

    'submission[xx]' :['Option 1','Option 2','Option 3']

    If it is not working, I suggest you get in touch with our API team. You may contact them via email at api@jotform.com.

    You may also want to check this page: https://developers.jotform.com/.

    Hope that helps. Thank you.

  • Profile Image
    kristiaansheedy
    Answered on November 29, 2017 at 10:31 AM

    What about the name field? 

  • Profile Image
    Mike_G
    Answered on November 29, 2017 at 02:29 PM

    We will be glad to help you with your concern, however, may we just know what programming language are you using and what exactly are you trying to do, please?


    Also, please let us know the API endpoint that you are using.

    For example: 

    submission[2_first]=First Name Value

    submission[2_last]= Last Name Value

    We will wait for your response.