WordPress Plugin: Seeming incompatibility with WordPress