Hover text is not being translated.

  • Profile Image
    cedricbrusselmans
    Asked on December 01, 2017 at 10:23 AM
    tooltip/rollover help texts appear in their default language (English) whereas they should appear in French...
  • Profile Image
    BDAVID
    Answered on December 01, 2017 at 10:33 AM

    Please share the form where translation issue on hint texts is happening.

  • Profile Image
    cedricbrusselmans
    Answered on December 02, 2017 at 09:13 AM

    Two issues here:

    1) hint text language is in English whereas it should be in French


    1512223964Screenshot 2017-12-02 19.42.13


    2) the form title and several subtitles are not appearing 

    1512223868Screenshot 2017-12-02 19.38.47



  • Profile Image
    TREVON
    Answered on December 02, 2017 at 12:10 PM

    I have tested the first issue and I could get the translation on my end. Kindly see demo below.

    1512234409Translation hover.gif

    On the second issue I managed resolving the issue by using Advanced editor to hnage the font to white.

    1512234616Font color change.gif

  • Profile Image
    cedricbrusselmans
    Answered on December 03, 2017 at 06:34 AM

    Hi Trevon,

    See below the issue in another field for the form Cadac Group BIM Price Calculator:

    In short the hover text is displayed in English whereas it should be displayed in the translated language i.e. French (I have had the same issue with other languages and other forms before):

    1512300715Screenshot 2017-12-03 17.01.12


    Can you please send me the ways to solve this issue promptly please?


    Thanks. 

  • Profile Image
    Mike_G
    Answered on December 03, 2017 at 10:01 AM

    Based on experience, I believe the issue you are having is caused when you copy/paste the text into the Hover Text of the field under the Advanced tab of the field's properties.

    There might be some extra, unnecessary formatted characters that were included when you copy/pasted the text, thus causing the translation to fail.

    So, to fix the issue, please try typing the hover text in manually instead of copying/pasting it from another source.

    Same goes for the translation — the translation of the hover text should be typed in manually.

    I hope this helps. If you have other questions or concerns, please feel free to contact us again anytime.