What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    Form Freezing Up - can't use it, embed it or save

    Asked by norm27 on September 19, 2012 at 01:37 AM

    I sent a support email to you guys but Mike suggested I post this here instead for a quicker answer.

     

    I have been using JF for about 4 years and I know my way around it. I have many, many forms.

     

    I have already cleared my cache & cookies, signed in and out, cloned the form ( it won't clone, if that's a clue, it says the owner has removed the form etc. when you try to preview the clone) 

    My other forms work fine, so I think it has to do with the size of this one (just a guess)

     

    Huge Problem: 

    I have to add something like 620 conditions.
    I cannot access the form, it is just freezing up.
    I already have a LOT of conditions in there.
    I can't save it, work with it or otherwise edit it- 
    it was working 100%, as I went through adding, I tested every now and then, but now my conditions are screwed up now too.
    In short, that form is rendered useless now. I have put many hours into it already, and as mentioned, I am on a deadline.
    Is your system able to handle this? Is it a temporary glitch?
    I need all the help I can get, as I need to finish this by tomorrow (for a client, you know how it is!) and I cannot understand the issue.
    It was all working fine, I was adding conditions then suddenly it started glitching.
    Should I get all the source code and then edit outside of the system (like in Dreamweaver or something) ?
    If the system can't handle it and I need to do it like that, could you please zip and email me the full source, because I can't even access that, it just freezes up.
    Please help me! Mail me back with any other questions etc.
    I need to work with you on sorting it out as soon as possible.
    And if I can't use Jotform for this, I'd be greatful to ANYONE has suggestions to a possible workaround using an external script or something please let me know.
    Thanks in advance for your help, I really appreciate it.
    Page URL:
    https://secure.adminplus.co.za/demo/khanyisa.html

  • Profile Image

    Answered by norm27 on September 19, 2012 at 02:26 AM

    Please help me out with the above - I need to finish this urgently, then upgrade this account if I can use jotform for this.

    Thanks for a great platform.

  • Profile Image
    JotForm Founder

    Answered by aytekin on September 19, 2012 at 02:34 AM

    No, 620 conditions is not something we have tested for. Also, in conditions it is very easy to create infinite loops or deadlocks. 

    If it was working before and just stopped working now, I'd try these things:

    - First, make sure to clone your form. It is possible for something to go wrong and lose your work. Use Clone feature on My Forms page to keep copies of your form. (If you've actually done this previously, you could have switched to an older but working version.)  

    - Remove the latest changes you made. If you added a new condition recently, that might be the reason. 

    - Try a different / faster browser. Google Chrome is pretty good at javascript execution. You should probably give that a try.

    - Make sure you do not have any conditions that depend on fields you have deleted previously.

  • Profile Image

    Answered by norm27 on September 19, 2012 at 03:11 AM

    Hi Aytekin.

     

    Firstly, thanks very much for your insights.

     

    - As I mentioned previously, when I try to clone, I rename and hit save, it doesn't save. It FREEZES up.

    - I only use Chrome. (Although I've tested in IE and FF, freezes everytime )

    - The issue is not so much the conditions, I've got those pretty much down

     

    The dashboard/admin area is unresponsive, is there some kind of size limit or something, or timeout or something that may be causing this?

    I really want to use Jotform for this, thanks for your help so far.

     

  • Profile Image
    JotForm Support

    Answered by idarktech on September 19, 2012 at 05:01 AM

    @norm27

    I was able to clone your form, yet it freezes but it's not taking too long on my end. My browser (Chrome) becomes unresponsive but I was able to edit fine. Though, I just need to be patience since the "saving" or "working" process may take some time, probably because of the form/content size. If you need your form source code, you can download it here. I'd also suggest to try it on a different PC, it may also help.

    Our apologies for any inconveniences caused. Thanks!

  • Profile Image

    Answered by norm27 on September 19, 2012 at 05:26 AM

    Hi idarktech.

    Thanks again for looking at this, appreciate your help.

    However, I have tried on a different PC (i5, quite quick) You mention the browser becomes unresponsive, it happens on my end too- this sort of prevents me from editing the form?

    Is there a possible workaround to this? Like pulling in external script that will do the job instead of having the conditions running through JF's Js?

    Or some way to increase allowed size limits or something for this particular case?

    The client has insisted that the form works this way and 'pulls' the initial selection through into the form, hence the conditions. 

    Not sure here, as I've obviously never had this issue before- all my other forms work perfectly, I realize it's the size.

    I am about halfway with this, so five minutes per edit is going to take days!

    I'm running out of ideas (and time) !

     

    Thanks again, please bear with me here...

  • Profile Image

    Answered by fxr on September 19, 2012 at 08:19 AM

    @norm27,

    With so many conditions on the form its highly likely the problem is there. 

    It does sound like some kind of bespoke javascript solution is the way forward for you as having 620 conditions may be unnecessarily over complicating matters. You would probably need to get a developer to write this javascript for you as, I can only imagine with all the different possibilities on your form, that the script is going to get relatively complex. 

    But as has already been alluded to, if the form did used to work, would it be possible to try and rollback the last condition changes you last made? Even if you need to roll back 30,40, 50 , at least you will be able to get your form working again, and will be more careful testing when adding them back in. 

  • Profile Image

    Answered by norm27 on September 19, 2012 at 11:35 AM

    Thanks guys.

    The form works now, but it times out three times on every save. Making it a little tedious.

    My conditions are set up correctly.

  • Profile Image
    JotForm Support

    Answered by liyam on September 19, 2012 at 01:42 PM

    Can you please try to clear your browser's cache again and try to save your form again?   This seems to happen due to your form being too huge

  • Profile Image

    Answered by norm27 on September 21, 2012 at 03:27 AM

    Still working on this form.

    Cleared cache etc, but every save is now timing out about 6 times and sometimes throws the ' form cannot be decoded' error.

    I cannot use it like this- will have to find another solution. Thanks anyway guys, JF is not going to be the solution this time.

  • Profile Image

    Answered by norm27 on September 21, 2012 at 12:50 PM

    PS- now I'm getting this error and it doesn't show the form at all:

     

    v8_build_source.js:38: Error loading file load( configFile + '.js'); ^

     

    What might that be?

  • Profile Image
    JotForm Support

    Answered by NeilVicente on September 21, 2012 at 03:23 PM

    @norm7

    I can't reproduce that error on my end, but just in case, I went ahead and cleared your account's cache.

    As for your original issue, I have a feeling that the numerous free text fields are what's causing the freezing problem.

    If, by any chance, you are able to edit your form, try replacing these text with regular unformatted text. Then perhaps you can style them using a single CSS declaration.