Encrypted form: The year part of the Date Picker field is sometimes not decrypted in the Email Notification

  • Profile Image
    pinnacleifs
    Asked on December 08, 2017 at 10:26 AM

    (This is an encrypted form!)

    Here is the issue:
    When a user submits a form we receive a notification email of a new encrypted response. We have the decryption key saved, and can simply click the button within the email to access the data via browser.

    However, sometimes, not all the time, the date fields will appear as though they did not fully decrypt. It doesn't happen all the time, and it doesn't apply to all date fields. I have seen the error happen regardless of browser the data is accessed from.

    I can see the data correctly if I log into JotForm and view the submission from the form itself (as opposed to via the email).

    Please see the screenshot to see the error.

  • Profile Image
    BJoanna
    Answered on December 08, 2017 at 12:51 PM

    I cloned your form and made few tests but I was not able to replicate mentioned issue. 

    I saw that you have a lot of date fields on your form. Is the issue always related to the same field? Also, is always only year not decrypted? Also is the issue related only to some specific date? 

    The form you provided has only 5 submissions. Do you have the same issue with some other form as well? 


    If the issue is related only to one specific field, you can replace it to see if that will resolve the issue. Do not delete the field because the data of that field will be deleted as well. Simply hide the field and add a new field.

  • Profile Image
    pinnacleifs
    Answered on December 13, 2017 at 10:10 AM

    It does always apply to the year segment of the date field. So we'll see the month and day, but the year will be replaced by encrypted text.

    There are several date fields and as best as I can tell it happens randomly - the date field will be random, and if it messes up or not is also random. I have another encrypted form that also has this same issue.

  • Profile Image
    BJoanna
    Answered on December 13, 2017 at 11:36 AM

    I cloned and tested your form again but I was still not able to replicate the issue you reported. 

    After that, I created a demo form with 30 Date Picker fields and this time I was able to replicate the issue. For some fields the year was not decrypted, but only inside of the email Notification. It is decrypted on the submission page, just link on your end.

    1513182773year.JPG

    I will report this issue to our developers and we will inform you via this thread once this issue is resolved. 

    For now, I can only suggest you to check the year on the submission page of your form. 

  • Profile Image
    pinnacleifs
    Answered on December 14, 2017 at 08:16 AM

    Okay thank you for submitting this to the developers. I'm glad you were able to reproduce it.

  • Profile Image
    ashwin_d
    Answered on December 14, 2017 at 11:18 AM

    This issue is already reported to our backend team. Upon checking the ticket status, I found that its already assigned and one of our developer is looking into this. Though we cannot provide an ETA on the solution but we will get back to you as soon as we have any update on this. 

  • Profile Image
    NeilVicente
    Answered on December 15, 2017 at 12:24 PM

    Hi,

    This should be fixed now.

    Can you please check and let us know if you're still having issues?

    Thanks!

  • Profile Image
    pinnacleifs
    Answered on January 03, 2018 at 09:08 AM

    Thank you, it seems to be fixed!