Source Code Embed: Uncaught ReferenceError - JotForm is not defined error in console

  • Profile Image
    rajeshmanoharan
    Asked on December 08, 2017 at 01:31 PM

    I have created a form for application filling and it seems its is not responsive and I could not able to click the next button for multiple pages while filling up in my mobile devices.

  • Profile Image
    jonathan
    Answered on December 08, 2017 at 02:53 PM

    Yes, the forms support all known mobile browsers as well. If you test your form on mobile device browser you will see it automatically responsive already.

    From what I have checked on your website, I see you have embedded the form using the full source code.  It appears that the embedded form was not the updated version of the form.

    I suggest you try first re-embedding again the form so that the updated version will be published. Then test again on your mobile browser. 

    Let us know if this did not resolve the issue. 

  • Profile Image
    rajeshmanoharan
    Answered on December 08, 2017 at 03:43 PM
    ​Is there any updation done recently in jotform​ regarding mobile browser
    support?
    ...
  • Profile Image
    EltonCris
    Answered on December 08, 2017 at 04:49 PM

    I can't actually move to the next page even on the desktop. 

    I've seen a few errors when I check the console log while on your page. It also triggers an error when clicking the next button.

    First, please try to re-embed your form using its source code as suggested by my colleague. Then re-implement your custom script. If it still throws an error, please check your custom script because clicking the next button gives this error which I believe a custom code.

    We'll await your reply.

  • Profile Image
    rajeshmanoharan
    Answered on December 08, 2017 at 06:43 PM
    The code was working good few days back both in desktop and mobile I have
    no idea what happened now..
    ...
  • Profile Image
    Jan
    Answered on December 08, 2017 at 08:50 PM

    Did you customize the source code and added additional fields? I checked the actual form in our database and it is not the same.

    Also, have you tried removing or editing the custom code mentioned by my colleague Elton? Is the next button working properly if you remove the script or function mentioned by Elton?

  • Profile Image
    rajeshmanoharan
    Answered on December 08, 2017 at 10:43 PM
    Yes I tried removing the script but still the result is the same. Even I have back up of all files deleted and uploaded again but still I could not move to next page..
    Get Outlook for Android
    ________________________________
    ...
  • Profile Image
    rajeshmanoharan
    Answered on December 09, 2017 at 12:43 AM
    Am getting Uncaught Reference Error: JotForm is not defined at index.php.
    It means that is there error in Css and Js files?? Should I download New
    css and Js files by creating new form??
    ...
  • Profile Image
    liyam
    Answered on December 09, 2017 at 05:27 AM

    Can you try getting a fresh code again and see if it resolves the issue? Also, if you are using a CMS like Wordpress, please try clearing your webpage's cache.  Here is a guide I found online about clearing caches on Wordpress: 
    http://www.inmotionhosting.com/support/edu/wordpress/recommended-wordpress-plugins/clearing-cache-in-wordpress

    Feel free to let us know if the problem persists.

    Thanks.

  • Profile Image
    rajeshmanoharan
    Answered on December 09, 2017 at 08:43 AM
    From the errors I get in console I can say that the js folder does not work completely...I even deleted all the custom codes created my me but still the problem persist. It works perfect in local server but while executing the form in my domain the problem comes as JotForm not defined and Reference Error..
    ________________________________
    ...
  • Profile Image
    Nik_C
    Answered on December 09, 2017 at 03:03 PM

    I see that error on your webpage, but the error doesn't persist if I download the source code of your form, and you said it worked on local one as well.

    Could you please try re-adding the Source code to your website without any additional (custom) scripts?


  • Profile Image
    rajeshmanoharan
    Answered on December 09, 2017 at 07:43 PM
    I already tested it without custom codes. There is always some error in js scripts.
    ________________________________
    ...
  • Profile Image
    EltonCris
    Answered on December 09, 2017 at 09:34 PM

    You're definitely right. I was able to reproduce the problem on a cloned version of your form. The form source code alone shows the JS error without any alterations made.

    I will forward this to our developers so they can further investigate. 

    We will let you know here once this is resolved.

  • Profile Image
    rajeshmanoharan
    Answered on December 09, 2017 at 09:43 PM
    Please do it soon as possible since we are using the from for daily use...please let me know once it is done..
    ________________________________
    ...
  • Profile Image
    EltonCris
    Answered on December 10, 2017 at 01:31 AM

    The problem is now fixed by our developer.

    Please retake again the source code and re-embed it on your website. It should be working now.

    Thank you for your patience.

  • Profile Image
    rajeshmanoharan
    Answered on December 10, 2017 at 02:43 AM
    Yes now am getting it right..Thanks a lot..May I know what was the issue and will it persist in later times??
    ________________________________
    ...
  • Profile Image
    EltonCris
    Answered on December 10, 2017 at 02:56 AM

    Glad to hear that it worked now.

    There was, unfortunately, an oversight on the recent update causing this to happen.

    This was fixed by our developers and some necessary changes were performed to prevent this from happening again.

  • Profile Image
    rajeshmanoharan
    Answered on December 10, 2017 at 03:43 AM
    Ok.. That is what am asking your team since Friday is there any updates done on your side....so that it is not working for me..
    ________________________________
    ...
  • Profile Image
    Nik_C
    Answered on December 10, 2017 at 04:08 AM

    We're sorry for this inconvenience and delay. The issue shouldn't happen anymore since necessary tests are implemented to prevent this issue from re-occurring.

    Thank you for your patience.

  • Profile Image
    rajeshmanoharan
    Answered on December 10, 2017 at 04:43 AM
    Ok thanks a lot again...if any issues will revert you back..Have a great day..
    ________________________________
    ...