my e-mail submissions are not coming through

  • Profile Image
    rochelletorok
    Asked on September 20, 2012 at 05:56 PM

    I just created a new form called Firefighter Key Chains and set the e-mail alert to the correct address but my e mail submissions form that form are not showing up in my inbox or spam either.  I have successfully created and use other JotForm forms so I am not sure what is wrong with this one.

  • Profile Image
    Mike_T
    Answered on September 20, 2012 at 06:50 PM

    Thank you for contacting us.

    Please open your Email Notification and set the Sender E-mail to noreply@jotform.com. Then, re-check email delivery by submitting the form.

    1. Log into your JotForm account and go to My Forms section.

    2. Select the form and click on "Edit".

    3. Click on "Setup and Embed" tab on the form builder toolbar.

    4. Click on "Email Alerts" and select "Notification".

    5. Click on "Reply-To and Recipient Settings" button (third from the right along the bottom).

    6. Set the Sender E-mail to noreply@jotform.com

    7. Click "Finish" button.

    If that does not help, please let us know.

  • Profile Image
    rochelletorok
    Answered on September 20, 2012 at 10:18 PM
    Hi Mike,
    I followed your directions and still doesn't work. I even checked my html
    code and the uploaded the web page with the form button to my sever and
    tried it again. The form seems to be working fine but no submissions are
    showing up in Jotform for the form nor are they coming through to my e-mail
    account.
  • Profile Image
    idarktech
    Answered on September 20, 2012 at 11:01 PM

    @rochelletorok

    I see you have paypal payment field in your form. Unfortunately, notification wont send emails if you'll not complete the payment process after redirected to paypal. Failed to complete the payment process will result to Pending Submissions.

    I'd suggest to remove first the paypal payment field before making a test submission so you'll not get redirected to paypal and then restore it afterwards.

    Thanks!

  • Profile Image
    rochelletorok
    Answered on September 21, 2012 at 05:24 AM
    Thank you, I was wondering if that was the issue.
  • Profile Image
    idarktech
    Answered on September 21, 2012 at 05:40 AM

    @rochelletorok

    Were you able to make a test? Please let us know what your results are so we can assist you further. Thanks!