Webhook not even sending to Rquestbin

  • Profile Image
    xephoid
    Asked on December 13, 2017 at 03:24 PM

    Hi there,

    I have been testing out webhooks and have yet to see it work. I have a very simple web server that I wrote to test what the request looks like. I wasn't able to get a request so I switched to using RequestBin to see what was wrong, but it doesn't seem to send any request to RequestBin either.

    Am I missing something?

  • Profile Image
    aubreybourke
    Answered on December 13, 2017 at 04:46 PM

    Please follow the instructions here:

    How-to-Setup-a-Webhook-with-JotForm


  • Profile Image
    xephoid
    Answered on December 13, 2017 at 05:16 PM

    I did that.

    I set up a RequestBin:

    https://requestb.in/wzlrgvwz?inspect

    Added it to my webhook:

    1513203308webhook_not_working.png

    But when I fill out the form I don't see anything in RequestBin. I have refreshed many times.

  • Profile Image
    Jed_C
    Answered on December 13, 2017 at 07:35 PM

    Thanks for the response.

    You will need to make an actual submission using the your request bin link https://requestb.in/wzlrgvwz. I've tried your link and it was able to capture my sample post. 

    Here' what I see from my end:

    1513211600webhook.gif

    Have you checked the URL in your webhook integration and confirm if it's correct? If so, try making an actual submission and visit the request bin inspect page and see if the data has been passed on.

    By the way, I just followed the steps in our guide here https://www.jotform.com/help/245-How-to-Setup-a-Webhook-with-JotForm.

    Let me know if you have any questions.

  • Profile Image
    xephoid
    Answered on December 14, 2017 at 08:52 AM

    I see that your form works. I was able to submit your form and see it show up in RequestBin, but mine still doesn't. There must be some setting that is correct on yours, but not on mine, but I don't see it. You should be able to see from the screenshot I posted that the URL for RequestBin is correct. I have made over 80 submissions to my form:

    1513259455jotform_82_submissions.png


  • Profile Image
    aubreybourke
    Answered on December 14, 2017 at 10:41 AM

    I see that it seems to be working now. https://requestb.in/wzlrgvwz?inspect shows that the requests are being captured. Can you please confirm that the problem has been resolved?

    15132659922.png

  • Profile Image
    xephoid
    Answered on December 14, 2017 at 12:00 PM

    I made a new form and it works with that one. The original form still doesn't work and I don't see the difference between the two. I would like to understand why one works and the other doesn't.

    Here is the original form:

    https://form.jotform.com/73167445962162

  • Profile Image
    TREVON
    Answered on December 14, 2017 at 01:49 PM

    I have checked the difference between the forms and the only difference is the header. The first form does not have heading but the second form that worked has heading.

    Also the url you are using for the first and second form are you using http://www.jotform.us/form/73167445962162 or https://form.jotform.com/73167445962162. as this might also be one of the differences.

    Kindly try adding heading and confirm if it works and also try using one type of url and let us know which works.