Square payment field is not shown on the form

  • Profile Image
    jcistudentministry
    Asked on December 14, 2017 at 02:20 PM

    Hi There!

    I have just published a form using the square payment widget. No user except me is seeing the payment options when they use the form. The payment widget says that the connection is good and live. And I am seeing the payment options on both my desktop and on my phone. However, I have had 12 other people try to use it, and none of them have seen the radio buttons or fields for entering the credit card info. I have checked and rechecked everything I know to do. Do you have any ideas?

    Thanks,

    Jenifer

  • Profile Image
    BJoanna
    Answered on December 14, 2017 at 04:06 PM

    I am not able to replicate mentioned issue.The Square payment field is properly shown on the second page of your form. 

    1513285194sq.JPG

    Are your users still unable to see the field? 

    Is your form embedded? If so, please provide us the webpage URL so that we can test the form there. 

  • Profile Image
    jmartin123
    Answered on December 18, 2017 at 11:24 AM

    Hi! I work on this form, also. I am unable to recreate the issue, but less than half of the submissions we have been able to see the field. The form is not embedded. We use hyperlinks to open the form in a new browser window. 

    Thanks!

  • Profile Image
    Jan
    Answered on December 18, 2017 at 12:47 PM

    Unfortunately, I was not able to replicate the issue as well. The payment field is showing properly on the 2nd page. I have tested this on Google Chrome and Mozilla Firefox.

    I can also verify that there is no condition assigned to the payment field. It means that it should always appear in the form. Also, the payment field is required. It means that the form cannot be submitted if the payment field is blank.

    Is it possible that the users are not pressing the "Next" button? 

    I have cleared your form cache so that the forms on your account will be refreshed from our servers.

    Thank you.

  • Profile Image
    jmartin123
    Answered on December 18, 2017 at 01:43 PM
    Thanks for looking into this.
    No, it is not that they are not hitting the next button. I know this for a couple of reasons.
    They are submitting the forms (evidenced by the fact that their info is showing up in the submissions)
    I was able to recreate this issue at first, but then, all of the sudden, I was seeing the square widget. And I have not been able to recreate the issue since. I was hoping it was resolved until I found submissions without payment info with timestamps AFTER the day/time I was seeing the proper fields. Furthermore, I had a colleague test it. At first he was not seeing the square widget. Then, after several attempts, he was seeing it. Now he, like me, sees it every time he pulls is up. But not all of our users are seeing it.
    Also, the form is definitely submitting without that "required” field being completed, evidenced by the submissions report. So, something is not working correctly.
    I hope all that makes sense.
    I’d really like to get this resolved b/c one of the reasons we use Jotform over google forms is the ability to collect payments. We are now stuck hunting these people down to collect payments manually. Ugh! Thanks for your help. :)
    Jenifer
    ...
  • Profile Image
    Jed_C
    Answered on December 18, 2017 at 02:48 PM

    Apologies for the ongoing issue.

    Like what my colleagues tested, I'm unable to reproduce the issue as well. Are you able to confirm if there's any pattern where the form doesn't prompt for users like all EU, USA, Canada etc. users are not seeing this? I've asked this because I would like to know if it has something to do with the server where the users are trying to connect.

    Below is my sample screencast:

    1513626321summer_camp_test.gif


    Looking forward for your response.

  • Profile Image
    jmartin123
    Answered on December 18, 2017 at 03:43 PM
    Hi Jed,
    These are all USA users, specifically near Kansas City, MO. I have no idea what browsers or devices they may be using. I can tell you my experience, though.
    I had tested only through the form builder preview before I published it. (Yes! Rookie mistake) and I had no troubles with the form at all.
    I published the form and got several complaints that the users were not seeing a way to pay.
    I tested the published link myself and experienced the same thing yay was being reported.
    I could view the text box widget which gave some info about paying
    I was not seeing the Square widget
    I was able to proceed via the next button, where I was able to submit my form, never having completed the required Square info.
    I repeated this process on safari and chrome several times, with the same unsatisfactory results.
    I checked everything I could within form builder, settings, conditions, etc. Everything appeared in order.
    Eventually I tried again in safari, and it just began working. I immediately tested on Chrome from my computer, on safari from another Mac and on my iPhone. I also tried using the browsers in private mode. Everything worked and keeps working
    I can now no longer replicate the issue.
    My colleague was also able to replicate the issue initially, but suddenly it started working for him. Now he cannot replicate it.
    Is that any help at all?
    Thanks,
    Jenifer Martin
    ...
  • Profile Image
    jonathan
    Answered on December 18, 2017 at 05:06 PM

    From what I see on the latest existing submissions of the form, there were data on the payment field.

    Meaning users were able to submit the form and see the payment field. And the payment field was also set as mandatory or *required field -- the user will not be able to complete the submission unless they validate the payment requirement.

    Can you tell us the submissions that do not have payment on them?

  • Profile Image
    jmartin123
    Answered on December 18, 2017 at 06:43 PM
    Sure thing. I am attaching an edited version of the excel sheet I downloaded. I have removed all the personal data, as we are dealing with minors. But for each record, you will see the submission date, a last name and which Registration Fee product the user selected. The rows that do not have a registration fee product selected are the submissions that were made without filling in the *required Square integration field. These users reports never even seeing this field. You will notice that 15 of the 28 attempts to pay were allowed to submit without the mandatory Square field completed. However, this has not happened since the 14th. So, maybe it is resolved. I just don’t feel particularly confident that I don’t have other users who are abandoning their attempt b/c they can’t find the payment widget.
    Also, we plan to continue to use the Square integration for future registrations. I would like to proceed with that strategy confidently.
    Thanks,
    Jenifer
    ...
  • Profile Image
    Jan
    Answered on December 18, 2017 at 08:35 PM

    I checked your submissions and I can see that there are no payments made for some users on December 14, 2017. Here's a screenshot:

    151364686912-19-htvsn.png

    I checked the Revision History Tool of this form and I can see that there is a condition that was removed during this time. The condition is related to the "Registration Fee" field (payment field). Here's a guide on How-to-View-Form-Revision-History.

    151364691212-19-a9vjx.png

    It is possible that you are editing the form while the user is trying to complete the form. Do you know if your form is being edited during this period? 

  • Profile Image
    jmartin123
    Answered on December 19, 2017 at 10:43 AM
    Good Morning!
    I suppose it’s a possibility. But here is why I’m not convinced that it explains what was going on.
    The *required Square widget was not showing up before I opened the form to look at it. That is why I opened the form builder on the 14th in the first place. 11 people had tried unsuccessfully to pay using a credit card, and I was trying to figure out why.
    I do not know what time I opened the form to investigate the issue, but I know that at 2017-12-14 12:35:19, I successfully submitted the form, with payment. (You can see this one in the submissions record; it is the first with payment.) After that, I was done messing with the form. There are 7 more unsuccessful attempts after that. I was not editing the form then.
    I don’t think the time stamp on those revisions is accurate.
    The time stamp shows that I edited the Square payment product on the 14th, but I know for a certain fact that I edited those amounts on the 12th. As proof of my certainty, I offer the timeline of when I was told to change the cost.
    I got a message at 4pm on the 12th that the fee would be $399, not the previous amount of $400.
    In order to make that change, I had to edit the products within the Square widget as well as a couple of text boxes that gave the user some pertinent information.
    The revision history shows that I made the edits to the test boxes on the 12th but the edits to the Square products on the 14th.
    This is not accurate. I made all the edits on the 12th. My certainty in this lies in the fact that we were releasing the form on the evening of the 13th, but I had to leave town at 5:30am on the 13th, forcing me to get those changes done on the 12th.
    The only edits I made on the 14th were to remove two extraneous conditions that were attached to fields I had removed from the form awhile ago. I also confirmed that there were no weird conditions on the Square widget, that the Square widget was required, and that the Square widget was connected to our account. All these things were in order. I also tested the form using preview, and it worked perfectly.
    Another observation that makes me think the form revision history is not accurate is that I had to make the same price changes to a companion form (https://www.jotform.com/build/73333901340144 ), at the same time on 12/12, and I don’t see where these changes were recorded.
    Given the discrepancy in the revision history log, I wonder if there was some sort of delay in applying the changes I made to the Square widget on the 12th. Also, I have a couple additional thoughts about the Square widget.
    This form began as a clone of another form in which we used the Square widget. When I cloned it, the Square widget automatically connected to our account. I did not have to reconnect it. Is that what you would expect? I wonder if that created some issues.
    This wasn’t the first problem I had with the widget. I tried several times unsuccessfully to put this form into sandbox mode. The form builder would indicate that the form was in sandbox mode, but when I tried to test it, it would act weird. I can’t remember exactly what it was doing, but it wouldn’t let me submit the form while in sandbox mode. I eventually gave up on testing in sandbox mode and simply tested the functionality using a 100% off coupon. I don’t know if there might be any clues there.
    There is a lot of info in this email. Hopefully it helps. For my purposes, I will just keep my eye on the responses. If there are not any more submissions without payment, then it’s not an issue at the moment. But it does seem that there is/was something wrong with the widget that isn’t explained by anything we’ve yet proposed.
    Thanks for your help. JotForm has a remarkable culture of responsiveness. It’s one of the great things about this product.
    -Jenifer
    ...