Conditions Based On Form Language Selection: not longer working on Edit Submission URL

  • Profile Image
    RobertKRice
    Asked on December 18, 2017 at 11:35 AM

    My form allows users to receive an email of their submission and then to edit them.

    Any photos they have uploaded are included in the emailed form. However when they click the edit button in the email, the form that appears no longer shows the photos or the fields relating to them. If they resubmit, the new email does not include the photos in the body, though it may in the pdf. (see uploaded pic)

    Previously photos were included but there seems to have been a change in behaviour over the last few months. How can I reinstate the old behaviour please, as the facility to edit photos is essential for my users.

    many thanks

  • Profile Image
    david
    Answered on December 18, 2017 at 12:46 PM

    I tested with my own form and when editing a submission, I was able to update images uploaded using an image upload preview widget.  Here is an example test submission:

    https://www.jotform.com/edit/3894277876782621891

    When I checked your form though, it seems you have conditions that are hiding the upload fields based on language selection:

    1513619074Capture.PNG

    Those conditions are not triggering immediately so the fields are being hidden.  If you toggle the language selection, the appropriate fields should be shown.

  • Profile Image
    RobertKRice
    Answered on December 18, 2017 at 04:27 PM

    David

    Thank you for your prompt reply. I'm not sure what your test establishes, but you are right that the photos are restored by toggling the language button. This was not necessary 6 months ago, so I wonder what has happened ? I'd rather avoid user-visible workarounds, so any suggestions you have on how the problem can be cured properly (eg by inserting a dummy automatic trigger) would be most welcome.

    In the meantime, can you remind me how to get at the language widget in VERSION 3 to see what I can do for myself (and in due course add more languages). The user guide refers to the v4 menu so does not help.

    many thanks again

    Robert

  • Profile Image
    BDAVID
    Answered on December 18, 2017 at 05:49 PM

    I have been think of a workaround to trigger them automatically on edit mode, but that could cause more problems. Actually, the conditions with form languages should be triggered in edit URL as they used to do before. I have forwarded this to our back-end team to see if there is a way to make it work like before. You will be notified via this thread.

    On regards of your question "In the meantime, can you remind me how to get at the language widget in VERSION 3 to see what I can do for myself", that's not possible as version 3 has been discontinued already.

  • Profile Image
    janberk
    Answered on December 19, 2017 at 08:20 AM

    Hey, this should be fixed now. Thank you for informing us. If you have further issues please let us know.

  • Profile Image
    RobertKRice
    Answered on December 20, 2017 at 05:07 AM

    It works ! Many thanks for attending to this so quickly.

    I'll grapple with v4 in the New Year, so will let you know if I have any further issues then

    best wishes for the holidays

    Robert