Emails: conditional Logic not working

  • Profile Image
    SCFCU
    Asked on December 21, 2017 at 01:39 PM

    I have some conditional logic that sends emails after a signature field is filled. The signature field in is not completed until after the initial form is submitted. The initial notification email works just fine, which includes an edit link. The manager will go to the edit link to sign the form. After the signature is filled, the conditional logic does not seem to fire. Does logic not apply after the initial submission?

    Also, I have an email field to in form for alerts and some of the logic, but upon edit of the form it gives an error about the field not being filled in, even though it is filled in already, I have to click the filed a few times or hit the submit button a few times to get it to submit again after an edit.

    I have uploaded a screenshot of my conditions

  • Profile Image
    aubreybourke
    Answered on December 21, 2017 at 02:31 PM

    You nearly have it. But instead of using the two autoresponders you must use notifications. Then in your conditions specify your recipient email address or email field name. 

    Please try that. 

  • Profile Image
    SCFCU
    Answered on December 21, 2017 at 03:45 PM

    Thank you. I updated the emails to notifications. They only seem to send if I have "Send on Edit" enabled.

  • Profile Image
    aubreybourke
    Answered on December 21, 2017 at 04:13 PM

    Oh yes definitely. You need to enable that setting for the edited submission to send. Strange because it is enabled by default.

    In any case great that you got it to work mostly by yourself. Well done!