"submit.jotform.us" blocked by McAfee and preventing submission.

  • Profile Image
    galiciancr
    Asked on December 29, 2017 at 08:19 AM

    I have a form that have been working for months but yesterday we started to have problems in the moment of submitting but form was never change in any way.

    There is no way to submit, no matter if we use IE, Chrome or Edge, all show the same error webpage.

    Please, I need ur help asap.


  • Profile Image
    galiciancr
    Answered on December 29, 2017 at 09:28 AM

    I think it is related with mcafee blocking jotform submissions.

    Do you have any news for that?

  • Profile Image
    Kevin_G
    Answered on December 29, 2017 at 09:47 AM

    I have just tested your form and it worked on my end: 

    15145587041.png

    If you have installed the McAfee software then you need to check if the Jotform domain has not been blacklisted. Please also try with a different network and check which McAfee software you have and provide us with that. 

    I will also forward this to our second level so we can update you when this is resolved. 

  • Profile Image
    galiciancr
    Answered on December 29, 2017 at 09:58 AM

    Hi Kevin, 

    Thanks for your answer. 

    I've tried again and I have the same problem on my company network as they use MCAfee.

    When I tried from a different computer, not using mcafee it is working fine. 

    I read in another thread that you are working with mcafee to take jotform away from blacklist. Do you have any news for that?

    It is useless if we can't use in my companies network.

    Regards,

    Gonzalo

  • Profile Image
    Kevin_G
    Answered on December 29, 2017 at 10:10 AM

    Yes, we had a report earlier about the same and our second level already contacted McAfee about that, so far we do not have any news, but I forwarded this thread as well so you can be notified when there are any updates. 

    As a temporary workaround, I would recommend you to whitelist the domain "submit.jotform.us" on the McAfee product you're using, that may help to get the form working on your network while we get an update as well from our second level. 


  • Profile Image
    Kevin_G
    Answered on January 02, 2018 at 11:54 AM

    We have already contacted McAfee about this and this should be fixed on their next update. 

    Please keep us updated. 

    Thanks.