Preview/Publish: Revisions not showing up in live form.

  • Profile Image
    nikkib312
    Asked on January 02, 2018 at 09:47 AM

    The only way for me to see edits I have made to a form is via Revision Preview. When I use the regular "Preview Form" toggle, only my old version of a form shows up. I have already cleared cache multiple times.

    The form giving me the problem is here:

    https://form.jotform.com/73177093446159

    I need this form to mimic the behavior of the form I have here:

    https://form.jotform.com/52423543418149 

    The key component here is I need the form to require a PIN code before allowing the rest of the form to be filled out. For some reason, the first form which is the current one I am using will not update live regardless of publishing and clearing cache. I have gone line by line to ensure the previous year's version and the current look exactly the same but with no luck. Please advise.

  • Profile Image
    aubreybourke
    Answered on January 02, 2018 at 10:49 AM

    Did you try clearing the browser cache or clearing the form cache? I have cleared the form cache for you. So please try it again now.

  • Profile Image
    nikkib312
    Answered on January 02, 2018 at 10:56 AM

    Of course, the moment I hit "submit" on the question, the form started working. I HAD already cleared the broswer cache. Can you show me how one would clear the form cache?

    I am wondering if it had anything to do with me republishing the website that the form is linked from. I don't really see why that would impact how I was viewing the form on JotForm's website. Maybe it was just a timing issue (though I struggled to troubleshoot my own issue for 30 minutes before submitting the question.) Anyway, it is working now but perhaps you could show me how to clear the form cache? I assume that won't impact the previous submissions I already have collected from the form?

  • Profile Image
    aubreybourke
    Answered on January 02, 2018 at 11:04 AM

    It was definitely a cache issue.

    Please see this guide:

    How-to-Clear-Your-Form-Cache