None of my form fields are showing up in the "Submission folder name" for Google drive in the integration wizard.

  • Profile Image
    davidgoebelstate
    Asked on September 26, 2012 at 07:45 PM

    It was working fine earlier today, but now I am not getting any options in the integration wizard for the submission folder name.  I have cleared my cache and tried in both Firefox and Chrome but they are both having the same issue.  I have several basic fields in my form which should be showing up in the integration wizard, however it remains blank.

    Here is the form... http://form.jotform.us/form/22697566651163

  • Profile Image
    Rodjit
    Answered on September 26, 2012 at 08:36 PM

    Hi,

    I have cloned your form and tried the integration and seems to be working fine on my end, please check: http://pbrd.co/S07dOY, also, I have tried leaving the "Submission folder name" blank but I can still recieve the submissions.

    Please try to logout your gmail account (if you are login) and login back and do the integration again.

    Hope this helps and please let us know if the problem is still there so I can consult this to our development team.

    Thanks

  • Profile Image
    davidgoebelstate
    Answered on September 26, 2012 at 09:27 PM

    Ok, I just tested again on a different computer and it worked fine.  So it must be some kind of cache issue or something on my other PC.  Although I did clear all the cache in my browsers.  I will check again tomorrow when I am back at work.

  • Profile Image
    idarktech
    Answered on September 26, 2012 at 09:43 PM

    @davidgoebelstate

    Probably. You can also try it on other browser's like chrome and firefox.

    Feel free to update us regarding this issue. We would be happy to assist you here. Thank you.

  • Profile Image
    davidgoebelstate
    Answered on September 27, 2012 at 12:18 PM

    I rebooted my work PC and all browsers are working fine now.

  • Profile Image
    davidgoebelstate
    Answered on September 27, 2012 at 02:18 PM

    Well, it worked fine for a while but now I am having the same issue again today.  I cleared cache on the browser but still the folder dropdown menu is empty.  Any suggestions?

  • Profile Image
    Rodjit
    Answered on September 27, 2012 at 03:36 PM

    @davidgoebelstate

    Is this another integration to one of your forms or it is the same? You may want to remove first the integration and re-integrate it again or if it's a new, then please try to refresh your page and do the integration again. We are asking your patience for this process.

    Thanks

  • Profile Image
    davidgoebelstate
    Answered on September 27, 2012 at 03:57 PM

    I have tried on both existing forms and a brand new form as well as various browsers.  However, it keeps coming up with an empty dropdown box.

    On a side note which may or may not be related, I have noticed that sometimes the integration dialog box sometimes opens partially off the webpage and sometimes completely off. It appears to be random as I haven't been able to find a consistant pattern.  The other thing I have noticed is error messages in the browser.  Take a look at the screen shots below.

    http://pbrd.co/SoMiPv

    http://pbrd.co/SoLJFy

    http://pbrd.co/SoMMoW

    http://pbrd.co/SoMVbV

    These screenshots are from Firefox, but I have seen the same behavior in Chrome as well.

  • Profile Image
    Mike_T
    Answered on September 27, 2012 at 06:52 PM

    Thank you very much for provided information.

    Do you use a http://www.jotform.com domain to edit your forms?

    If yes, please also try with a http://www.jotform.us domain to see if that makes any difference.

    We are looking forward to hearing from you.

  • Profile Image
    davidgoebelstate
    Answered on September 27, 2012 at 06:58 PM

    Latest update...

    When I got the dialog box showing off the page (like this http://pbrd.co/SoLJFy) I immediately refreshed my browser a couple times which got rid of the dialog box.  I then clicked on the integration button, the dialog box opened in the middle of the page like it should, and then I was able to select a folder in the dropdown menu.  So I am guessing that something is getting hung up in the browser and hopefully refreshing at that point in time is the fix.  However, I will let you know for sure next time around as I suspect it will happen again.

    note: I had been working in jotform.us but I just noticed in my browser that I am now in jotform.com

    hmmm.... wonder if that is the issue?

  • Profile Image
    Deygus
    Answered on September 27, 2012 at 07:03 PM

    Try integrating it using the method that was provided above your last message from my colleague Mike_T by using a different domain of jotform and let us know how that works out if at all. I look forward to your response about the issue.

    Correction, I see you technically tried this as well therefore I believe this issue has gone on long enough and I am refering it to our Developers for them to look at and help investigate.

  • Profile Image
    davidgoebelstate
    Answered on September 27, 2012 at 07:09 PM

    Both domains are working fine now.  The original issue was in the .us domain.  I will be sure to note the domain if/when it happens again.  Until then, the fix appears to be refreshing the browser when the integrations wizard dialog box is showing off the webpage.  For whatever reason that seems to have done the trick.

    I will keep you posted and thanks for the great support!

  • Profile Image
    Deygus
    Answered on September 27, 2012 at 07:22 PM

    No problem and that is good. I am still going to mark this as a bug with a request for our developers to look into since the Drive Integration is still new so it may be possible for this to be a bug so it wouldn't hurt to look into it more after going on this long as this will help ensure that it is stable.

    If your problem changes or gets worse please let us know and we look forward to any future responses you might have about it if any but hopefully it is working properly for you.

  • Profile Image
    davidgoebelstate
    Answered on September 28, 2012 at 02:58 PM

    Update: Having the same issues again today.  However, the reload trick I noted above is not working. It seems that the issue is completely random at this point.  

    Another problem that has also started to take place is that integrations are also randomly losing their connection as well.  The form shows that they are conected, but new submissions are not being sent to Google Drive. I can disconnect and then reconnect, but then it compounds the problem by creating a new folder in Google Drive.  I then have to manually move over the entries from the other drive (not a big deal), but the bigger issue is all of the submissions that never got sent to Google Drive after the connection stopped sending (whenever that might have been).

    Related thread... http://www.jotform.com/answers/134151-Existing-form-no-longer-sending-data-to-Google-Drive

  • Profile Image
    EduardoMendez
    Answered on September 28, 2012 at 03:10 PM

    @davidgoebelstate

    Thank you for updating us of the situation and helping us with the details.  

    There is a ticket open and marked as "urgent" in priority.  Our dev team is looking into it.

    However, a quick remainder of the limitations of the integration (quoted from one of my colleagues response): 

    If the form was edited/updated and then re-integrated, will create a new instance of the google spreadsheet. This is the current behavior of the integration.

    As long as you do not edit/update elements on the form (i.e. add/edit labels), the spreadsheet will not change or create a new set.

    What we can advise is to "finalize" form before finally integrating it to google spreadsheet. This way, the changes on the spreadsheet will be minimized. You can actually make revisions on the spreadsheet end (i.e. insert column, formulas, rows.. so on) without altering the form.

    BUT just do NOT change the column names on the spreadsheet that were derived during the integration. Because if this happen, the integration will be broken, and the succeeding form submission will fail to map to the appropriate column/fields.

    Btw, a feature request ticket was already submitted to our dev team to request to modify the current behaviour. We will be informed when this feature gets updated. 


    We will inform you of any updates on the issue!

  • Profile Image
    davidgoebelstate
    Answered on September 28, 2012 at 04:40 PM

    Thanks for the info.  In the meantime I have deleted/trashed all of my existing forms and have started from scratch.  I don't believe that I modifed my previous forms after setting the integration, but this time around I will make sure that I don't.  So if the integration fails again it won't have anything to do with modifying the form.  Stay tuned.

  • Profile Image
    davidgoebelstate
    Answered on September 28, 2012 at 06:36 PM

    Ok, there is definitely some kind of bug with the integration as I just submitted a new entry on the form but it did not get pushed to Google drive.  It worked earlier today and I have not made any changes to the form since, but now it is no longer sending.  I checked the integration wizard and it still shows as being connected and pointing to the correct drive, but nothing came over.

  • Profile Image
    EduardoMendez
    Answered on September 28, 2012 at 07:09 PM

    @davidgobelstate

    We apologize for the inconveniences that you have been experiencing.  

    I am testing to reproduce the problem but have not been able to do it so far. Please refer to this thread for this issue with your submissions and let us know as many details as you can in order to better troubleshoot.  

    Thank you for your patience.  We will update you as soon as we have a solution.

  • Profile Image
    canerbalci
    Answered on October 30, 2012 at 11:32 AM

    hi david,

    i just commited a fix for the bug, thanks for reporting the issue. please feel free to write here if you keep getting the same error. we highly appreciate your feedback.

    have a nice day.

  • Profile Image
    davidgoebelstate
    Answered on October 30, 2012 at 11:42 AM

    Will do, thanks.