Form not updating unless cloned

  • Profile Image
    soupiesales2017
    Asked on January 02, 2018 at 05:43 PM

    I am trying to update my form which is: https://form.jotform.com/80016608384152

     

    However, the changes I made in the Soup Type and Quantity section are not showing up in preview mode nor are they updating on my website (embedded using iFrame). I have cleared both form cache and browser cache on all devices. 

     

    I have also tried visiting the form in incognito mode but with no success.

     

    Screenshot is of the form in build mode with updates made.

  • Profile Image
    Jan
    Answered on January 02, 2018 at 07:30 PM

    I checked the form you have provided and I can see that it is the same with the screenshot you shared. Here's a screenshot:

    151493900301-03-pji99.png

    If the changes are still not showing, please try to replace the subdomain from "form" to "www". Here's the link: https://www.jotform.com/80016608384152.

    I cleared your form cache so that your forms will be refreshed from our servers.

    Hope that helps. Let us know if you are still having the same issue. Thank you.