Form takes very long to load - What is causing this problem?

  • Profile Image
    CalderElearn
    Asked on January 06, 2018 at 09:08 AM

    Hi Adrian and Kevin,

    I'm still facing serious problems when opening the form and i can't get figured out what causes the problem.
    I can see the form in its original layout but it takes now more than 50 (!) seconds to load the form. This was never the case.
    Because we are using the forms for our examination, this is not acceptable for the end-users.
    Perhaps you can explain to me why it is taking so long to load this form? We never had these problems before (that is in version 3) but in version 4 we keep on facing new problems. I hope you understand that i'm getting a bit tired.What am i doing wrong?

    In my previous questions i explained how we use the forms for examination of our student (more than 2500 students annually divided over 15 different kinds of education, for every student we use approximately 8 different forms). So you understand how important it is to us, that te forms function well. This was never a problem - until recently (when we were forced to upgrade from version 3 to version 4).

    How do we use the forms for examination? 
    The examination and grading is partially done by the company where the students does his internship, and partially at school. The results are added together to complete the grading. Finally our examination-office (examenbureau) checks the results and makes them final.

    Each examination leads to only one submission (record or row) in Jotform. 
    The grading-process starts at the internship company. 
    When the internship company submits his grading, the schoolexaminer gets an e-mail with an edit submission link so he can do his grading part.
    When the schoolexaminer submits his grading, the examination-office gets an e-mail with an edit submission link to make the grading final.
    Finally al participants (inclusing the student) are informed by mail about the final grade.

    So the process starts by sending a URL to the internship company. The URL looks like this:
    https://form.jotformeu.com/80023619398359?key=toegangscode&examenkandidaat=Marieke van den Beld&studentnummer=222222&leerweg=BOL&organisatie_bpv=Huisartsenpraktijk de Wit en de Jong&examinator_BPV=Geurtsen&email_bpv=heinie.raaijman@capabel.nl&examinator_COG=Heinie Raaijman&email_cog=heinie.raaijman@capabel.nl&email_exburo=heinie.raaijman@capabel.nl&beoordelaars=Beide&fileupload=BPV

    You can try it yourself by changing the emailaddress (heinie.raaijman@capabel.nl) to your email - then you can test how it works.

    I dont'know why the form is taking so long to load.What am i doing wrong?
    Has this to do with something i did (or not did) or has there been an change at your side that causes this problem?
    It is very important for us to solve this problem, because we currently are developing the new forms for the eamniation (2017-2018) and the form yhou are currently looking at will be used as our 'masterform'(and being cloned).

    Please help me out becaus I'm desperate.
    With regards,
    H. Raaijman

  • Profile Image
    Adrian
    Answered on January 06, 2018 at 09:33 AM

    I tried to open your form and it is true that it is taking long to load completely.

    Let me investigate it a little bit more and I will try to see what is causing this.

  • Profile Image
    Adrian
    Answered on January 06, 2018 at 10:13 AM

    Can you please tell us when did this start to happen?

    Some HTTP Requests are taking too long to complete. It looks like a server issue.

    I will forward it to Level 2 and we will let you know when there is an update.

  • Profile Image
    CalderElearn
    Answered on January 06, 2018 at 12:15 PM
  • Profile Image
    Adrian
    Answered on January 06, 2018 at 01:31 PM

    Our developers will look into the issue as soon as possible.

    We will let you know when this gets fixed.

    Thank you for your patience.

  • Profile Image
    Jeanette
    Answered on January 07, 2018 at 02:44 PM

    We've been informed that the issue was resolved

  • Profile Image
    CalderElearn
    Answered on January 08, 2018 at 06:02 AM

    Dear Jeanette,

    Thanx for jour answer.

    I just tested the form myself, but i'm very sorry to disappoint you: the loading of the form is still unacceptible slow. It still takes more than 35 seconds before the form is loaded completely. Especially the loading of the widgets seems to consume much loading time.
    After 15 seconds I see the first message '... processing data-widgets.jotform.io ...'  and after nearly 30 seconds i see a further message '... processing widgets.jotform.io ...'

    To be honest: Yes, there is a progress compared to the former situation but the performance is till so slow that I don't agree that the issue is resolved.  

    Second: After the form is loaded, there is a massive delay when I try to type characters in the input fields. Feel free to try it yourself (see the URL above).

    Third: The output is mysteriously altered - but I wil post a new request for that issue (because it refers to an earlier issue)

    We never had these kinds of problems before (Version 3), but in Version 4 we constantly are facing unexspected problems and results. Is there an explanation why the performance is so slow? Am i doing something wrong? Do i have to alter the setup or layout of my forms in Version? 

    I hope you don't find me annoying, but my business depends on the reliability of Jotform.

    H. Raaijman

  • Profile Image
    Adrian
    Answered on January 08, 2018 at 07:26 AM

    I noticed that your form has more than 40 conditionals and is using a lot of widgets.

    Please try to remove any widget that is not really necessary as this might improve the performance of the form.


    Our developers are looking into the case again (slow load time) and we will let you know when there is an update.


    Thank you for your patience.