When having my team submit a form, it is saying please wait and is stuck on this "please wait" screen for a long time.

  • Profile Image
    MAGPEPSI
    Asked on January 10, 2018 at 04:56 PM
  • Profile Image
    Jan
    Answered on January 10, 2018 at 07:53 PM

    I did a test submission in your form and it was successful. After hitting the Submit button, it redirected me to the Thank You page.

    1515631927testsubms.gif

    Is this form embedded on a webpage? If yes, then please try to re-embed the form using the iFrame method. Here's a guide: https://www.jotform.com/help/148-Getting-the-Form-iFrame-Code.

    If the issue persists, then please provide the URL of the webpage where the form is embedded so that we can further investigate.

    Thank you.

  • Profile Image
    MAGPEPSI
    Answered on January 10, 2018 at 08:41 PM

    This issue isn't on the form "Jennifer Events" but there is an issue with "Keely events" form

  • Profile Image
    Jan
    Answered on January 11, 2018 at 02:14 AM

    Unfortunately, I was not able to replicate the issue on the "Keely events" form as well. I did a test submission and it was successful. Here's a screen capture:

    1515653945testsubms22.gif

    Are you still experiencing this problem? If yes, then please try to test if it will work on another browser or not. You may also need to clear the browser cache of the non-working browser.

    I have cleared your form cache so that your forms will be refreshed from our servers.

    Hope that helps. Thank you.