Document uploaded in WebMerge is showing blank space.

  • Profile Image
    ZeshanHaider
    Asked on January 11, 2018 at 12:38 AM

    Hi,

    I have created a jotform and then inserted some merge fields in a word document. Then I uploaded that document in WebMerge. Then with the help of Zapier, I connected those merge fields with the corresponding jotform fields. Then I filled and submitted the jotform. Then I received the mail with that document and in that document most of the merge fields were replaced by the data I had entered while filling the jotform but the problem is that the values of fields labeled as "Email" did not replace their corresponding merge fields in the document. Blank space replaced these merge fields even though I had filled all the email fields while filling the form. All other merge fields were replaced by the data I had entered while filling the jotform. The only problem is with the fields labeled as "Email". Note that type of these email fields is Short Text Entry just like the other fields that I have created in the jotform.

    Need help as soon as possible. Thanks

  • Profile Image
    ashwin_d
    Answered on January 11, 2018 at 06:03 AM

    I am not sure if I have understood your question correctly. 

    I would suggest you to please share a screenshot of the document you have received in submission email with blank space and we will take a look. Please check the screenshot below on how to upload image in forum post:  https://www.jotform.com/help/438-How-to-Post-Screenshots-to-Our-Support-Forum

    You may also like to let us know the zap you have used.

    We will wait for your response.

  • Profile Image
    ZeshanHaider
    Answered on January 11, 2018 at 08:14 AM

    This is the screenshot of a part of the document that I had uploaded on webmerge:

    1515676283This is the screenshot of a pa


    This is the screenshot of a part of the document that I received after form submission:
    1515676369This is the screenshot of a pa


    Zap used:
    1515676430zap used.png

  • Profile Image
    ashwin_d
    Answered on January 11, 2018 at 09:34 AM

    Just to confirm that the zap you are using is:    https://zapier.com/apps/jotform/integrations/webmerge/300/create-personalized-documents-from-jotform-with-webmerge 

    https://zapier.com/apps/jotform/integrations/webmerge

    To test this issue, I would suggest you to please send the word document to us and we will take a look. You can send us an email with word document attachment at support@jotform.com. Please ensure the subject line of the email should be "Thread #1345557"


  • Profile Image
    ZeshanHaider
    Answered on January 11, 2018 at 09:43 AM

    Yes, I am using that zap.

    Ok. I am sending via email

  • Profile Image
    ashwin_d
    Answered on January 11, 2018 at 10:48 AM

    We have't received your email yet. Please send us a message once it is sent out. 

  • Profile Image
    ZeshanHaider
    Answered on January 11, 2018 at 11:02 AM

    It has been sent

  • Profile Image
    Adrian
    Answered on January 11, 2018 at 01:18 PM

    I see you have multiple Email fields on your form.

    Did you make any change after merging the fields using Zapier?

    The Unique Name of the Email field might have changed after you made the merge.


    Please try making the merge again and let us know if the issue persists.

  • Profile Image
    ZeshanHaider
    Answered on January 12, 2018 at 10:28 AM

    I have tried making the merge again but still the issue persists

  • Profile Image
    Adrian
    Answered on January 12, 2018 at 11:06 AM

    Please make sure that you select the right Email field on your form during the field matching process.

    1515773043fields.png


    Can you please go to Zapier and check the to which JotForm field is the email field matched to.

    A screenshot would be great. How to Post Screenshots to Our Support Forum


  • Profile Image
    ZeshanHaider
    Answered on January 12, 2018 at 12:10 PM

    Which is the best way to ensure that your connecting to the correct field when there are so many fields labelled as email?

  • Profile Image
    BDAVID
    Answered on January 12, 2018 at 01:08 PM

    You may put a unique label name(Email 1, Email 2, or Subscribers Email, Principals Email, etc) to each email field to identify them better.

  • Profile Image
    ZeshanHaider
    Answered on January 13, 2018 at 12:09 AM

    I have now made sure that I am selecting the right email field but still the issue persists

  • Profile Image
    ZeshanHaider
    Answered on January 13, 2018 at 04:50 AM

    waiting for your kind reply

  • Profile Image
    ZeshanHaider
    Answered on January 13, 2018 at 09:06 AM

    please tell me you're going to reply or not

  • Profile Image
    ashwin_d
    Answered on January 13, 2018 at 01:25 PM

    Please note that when you reply in thread, it is reassigned in queue.

    I will try to test this issue and get back to you if I have any questions.

  • Profile Image
    ashwin_d
    Answered on January 14, 2018 at 06:02 AM

    I cloned your form and trying to test this issue but I am unable to replicate it. As asked earlier, please send us the word file which you have uploaded in WebMerge account and used in the integration.

    You can sent it in an email or share a link, we will take a look. The document which you have shared is actually a PDF file but we would like to see the word docx file and also share the screenshot of the zapier "Edit Template" configuration where you have mapped the fields as displayed in the screenshot below:

    1515927708webMerge.png


    We will wait for your response.

  • Profile Image
    goquote
    Answered on January 15, 2018 at 08:03 AM
     
  • Profile Image
    goquote
    Answered on January 15, 2018 at 08:07 AM

    I am really sorry I will reply after a while

  • Profile Image
    ZeshanHaider
    Answered on January 16, 2018 at 01:01 AM

    I have now sent the word file which I uploaded in WebMerge account and used in the integration at this email: support@jotform.com with the subject: Thread #1345557

    I sent the wrong one first by mistake. Then I sent the correct one. The correct one is with the name "Complete (4)" 

    Here is the screenshot of the zapier "Edit Template" configuration where I have mapped the fields:
    1516082210david.png

    1516082457david.png

  • Profile Image
    Adrian
    Answered on February 20, 2018 at 10:04 AM

    Hello,

    First, we are very sorry for this late reply.

    The document that we received in the email has this filename "Application for Naturalization - Latest (3).docx".

    I have cloned your form, uploaded this document to WebMerge and set up the integration using Zapier.

    The email fields seem to be filled correctly.

    1519138939wm1.png

    If the issue hasn't been solved yet, please send us the correct document if this is no the proper one.