Data from one field being added to another field in email submission

  • Profile Image
    input
    Asked on January 11, 2018 at 09:01 AM

    In a number of forms the data from the telephone number field is being added to another field, sometimes at the beginning and sometimes at the end. It has inserted the number into a message field but also added a number on to the end of an email address.It is also stripping out the initial 0 from the telephone number.

    This does not happen in every submission but around 20% of the time.

    Technical support have known about this for months and keep on promising to deal with it but have not. Very poor support!

    Info has been redacted from the screenshot attached.

  • Profile Image
    BJoanna
    Answered on January 11, 2018 at 10:40 AM

    I saw that you already reported the same issue on this thread - https://www.jotform.com/answers/1253678 

    Your issue is already escalated to our developers. I checked the priority of that thread and it is set to urgent. I will also check with our developer to see if there is an update regarding your issue. If there is we will update you on that thread. 

    Just to check - Is the form that is causing the issue you reported embedded? If so, please provide us the webpage URL, so that we can test the form there. 

  • Profile Image
    input
    Answered on January 11, 2018 at 10:44 AM

    It is not embedded and is happening with a number of forms although they were cloned from one form. I have posted publicly because was not getting any answer from my private posts and I have been ignored for months.

    You have many screenshots of this happening with various forms over a number of months and this was escalated months ago with no answer.

  • Profile Image
    BJoanna
    Answered on January 11, 2018 at 11:59 AM

    Sorry for the inconvenience this may caused you. 

    I saw that you reported your issue back in October. I also saw that our developer ceren replied to your in December and that she mentioned that she will be checking your form logs to find the cause of the issue. Like I previously mentioned the priority of your issue is set to urgent, which is the highest priority. I also sent her a message to check if there is a new update. 

    I can only assume that there is an issue with your original form and that the same issue sometimes occurs on your other forms, because they are were cloned from the original form. 

    Until this issue is resolved, I can only suggest you to create a new form and check if you can replicate the same issue there.

  • Profile Image
    input
    Answered on January 11, 2018 at 12:47 PM

    I have had no response regarding the checking of the form logs. Also if I create a new form to replace an existing one there will be no continuity of submission reporting so I do not want to do that.

    The error is intermittent so it would be difficult for me to test all the time.

  • Profile Image
    Adrian
    Answered on January 11, 2018 at 02:09 PM

    We are very sorry for the inconvenience caused.

    Your case is already opened in another thread.

    I suggest you try and create a fresh form and Import the data from another form using this tool.

    https://apps.jotform.com/app/import_data


    I know this is not a solution but it would be good to see if the issue is replicated in the new form.


    We will let you know when there is an update on this on the other thread that the developers are assigned to.


    Thank you for your patience.