Upload Attachments & Matrix Dynamique Widget from Mobile Device Issues

  • Profile Image
    elgen.cm
    Asked on January 11, 2018 at 01:52 PM

    My form has sections that require the user to upload a document or image to the form.  When I tested it out on a mobile device, it allows the file to be attached but then does not allow the user to click next.  


    Also, the Matrix Dynamique widget does not display on the form when accessed from a mobile device.  The question displays but the field boxes do not display. Is this normal?

  • Profile Image
    jonathan
    Answered on January 11, 2018 at 03:12 PM

    I checked your form but I could not properly test the issue you reported due to the skip pages conditions on the form.

    I could not identify yet the answer combination to see the Upload field and Matrix dynamique widget options.

    1515701070zzz 2018-01-12 04.00.21.png

    The form have a lot of conditions already but on my test I was able to reach the Submit button anyway. The Next button had been working thus far when I test the form.

    1515701185zzz 2018-01-12 04.02.15.png

    ---

    For initial troubleshooting please check the following.

    1. You could probably not be able to go to Next page due to issue with Skip page conditions. There could be conflicting skip page condition. 

    2. There could be a *required field hidden within the page -- because it is hidden the required validation will not become true, which will prevent the Next button moving forward.

    3. Update the matrix dynamique widgets by clicking on the Update Widget button.

    1515701457zzz 2018-01-12 04.01.16.png


    Please double checking the mentioned items first on the form. Let us know if still not working even after checking/correcting them.



  • Profile Image
    elgen.cm
    Answered on January 15, 2018 at 11:46 AM

    You may be misunderstanding.  Both fields work fine on the form when viewed from a web browser on the desktop. 

    The problem is that it does not display the matrix dynamique field when accessing the form from a MOBILE device browser.
      As for the upload field, it displays on the mobile browser but once the file is uploaded, it does not allow the user to continue with the form when they click NEXT.
  • Profile Image
    Nik_C
    Answered on January 15, 2018 at 01:18 PM

    Please allow me some time to work on your form. I will get back to you once I finish.

    Thank you!

  • Profile Image
    Nik_C
    Answered on January 16, 2018 at 05:24 AM

    Thank you for your patience.

    I was able to replicate the Matrix dynamique widget and that it is not responsive on mobile. I escalated that issue in this thread: https://www.jotform.com/answers/1350467

    Regarding the file upload field issue, could you please tell us which field is affected so we can test this? 

    I checked some of them but I wasn't able to replicate this issue.

    Thank you!

  • Profile Image
    elgen.cm
    Answered on January 16, 2018 at 09:20 AM

    I have a couple file upload fields on the form and hadn't tested all of them yet on mobile but the one that I did test and had trouble with was the one that asks for pictures of the product to be uploaded.  It is on page 12 of my form. 

  • Profile Image
    Richie_P
    Answered on January 16, 2018 at 10:35 AM

    I have tested your form and I can click the next button after uploading my image using my android mobile device. I have chosen RMA then reason for RMA:Defective Product and then I uploaded my picture then clicked Next.

    I was using an android mobile device and opened the form using Chrome.

    May we know what mobile device you are using and what web browser?

  • Profile Image
    elgen.cm
    Answered on January 16, 2018 at 11:02 AM

    I was using iphone.  I just tested again and it seems to be working now. Thanks.  I will wait to hear back on the other issue on thread: https://www.jotform.com/answers/1350467

  • Profile Image
    Richie_P
    Answered on January 16, 2018 at 11:14 AM

    Good to know the issue has been resolved.

    I have checked the status of your thread-https://www.jotform.com/answers/1350467 and the ticket is already assigned to one of our developers and the priority is set to important.

    You will be updated via that thread.