HELP... My forms have stopped working properly

  • Profile Image
    call4angel
    Asked on September 30, 2012 at 04:37 PM

    Hello,

    I'm not sure what I did or didn't do, but my forms (conditions part(s) and autoresponders) are not working properly anymore.

    When I choose "female" and click "next" the form does not go to the next page (female questionnaire).

    When I chose "male" and click "next", the forms takes me to the female page BUT, in my autoresonder, it sends me the male submission (which it should), except "female" info was inserted....

    Also, the full thank you message does not show. The "thank you" page seems to be cut in half.

     

    How do I fix this?

     

    Thanks & Have a Great Day!

    Angela

  • Profile Image
    liyam
    Answered on September 30, 2012 at 07:35 PM

    Hello Angela.  This may have been caused by the form collapse (since part of the system treats it as a page while the condition does not).  Removing the form collapse will make your form work fine.

    Regarding your Thank You message, do you have a sample screenshot on how it looks like?  I'm suspecting that the black text camouflages with the black background, so changing all the black texts to white or another light color will make the thank you message visible.

  • Profile Image
    call4angel
    Answered on September 30, 2012 at 11:13 PM

    Thanks.

    I would like to keep the form collapse.

    I changed the conditions to show/hide a form field instead of skip.... but I'm still having issues with the Male condition (it shows the female form instead of the male form)... Any ideas?

     

    I will put the thank you message on a different url.

  • Profile Image
    danieldlopezp
    Answered on October 01, 2012 at 03:30 AM

    Hello Angela,

    I was taking a look to your form and I discover that the principal problem with your conditions is the way that you configured your page breaks, I cloned your form and I made some changes in the page breaks and now it works good I think. Please take a look of this form. If you want you can clone it and edit it as you wish.

    Please let us know if you need something else and we will gladly help you

  • Profile Image
    guest_22740997748066
    Answered on October 01, 2012 at 08:27 AM

    Thanks Daniel!

    The form you created works fine (except for the "back" & "next" buttons at the end of the male form - I should be able to take care of that).

    I do see you added another page break at the end of the form. Is this all you did? The conditions seems similar to my original conditions (until I added the page collapse).

    I would like to know what other changes you made so that if it recurs, I can take care of it.

     

    Blessings & Best regards,

    Angela

  • Profile Image
    liyam
    Answered on October 01, 2012 at 10:06 AM

    Hello Angela.  As it appears, yes, the page break was just added at the bottom so to add the 5th page to compensate the missing 5th page created by the form collapse.  Aside from that, no additional elements were added.

    The fastest way to get the form fixed by Daniel is to clone it to your account.  You can follow this user guide on how to clone forms.

    Here is the link of the form to be cloned:  Link to form

    If you have other questions or concerns, please do let us know.

    Thanks.

  • Profile Image
    call4angel
    Answered on October 01, 2012 at 10:10 AM

    All the forms have been updated and are working perfectly!

    Thanks so much for your help Liyam & Daniel!

     

    Have a Great Day!

     

    Blessings & Best Regards,

    Angela

  • Profile Image
    moonzkie
    Answered on October 01, 2012 at 10:19 AM

    Glad everything is working fine now, if you have further questions feel free to contact us.

    Thanks for using JotForm!