Jotform "Email Recipient" Changes Not Taking Effect

  • Profile Image
    dalerheaume
    Asked on January 15, 2018 at 08:47 AM

    I have changed the email recipients on a jotform; however, the changes are not being recognized when submitting jotform.  The recipients that were added are not receiving, and the old recipients removed continue to receive.

    Please advise how to fix or correct.

  • Profile Image
    ashwin_d
    Answered on January 15, 2018 at 11:20 AM

    I'm sorry for the trouble caused to you. 

    I did check the notification email alert of your form and found that you have added 3 recipient email address. Please check the screenshot below:

    1516032793recipient.gif

    Do you mean to say the submission emails are not being sent to these three email addresses? I would suggest you to please let me know on which email address you are receiving submission email and we will take a look.

    We will wait for your response.

  • Profile Image
    dalerheaume
    Answered on January 15, 2018 at 02:02 PM

    That is a different form.  The form I am concerned about is titled "Harnessing Request for Quote".  I removed the email "readychains@igus.com", and replaced with the three email addresses shown in the following image.  The changes appear to have not taken place on your end, and emails continue to go to the deleted email address "readychains@igus.com".

    1516042919Harnessing Request for Quote f

  • Profile Image
    aubreybourke
    Answered on January 15, 2018 at 04:20 PM

    I checked your form Harnessing Request for Quote and found that it has been set correctly:

    1516051061The Easiest Online Form Builde

    Can you try again please?

  • Profile Image
    dalerheaume
    Answered on January 16, 2018 at 09:35 AM

    I tried another TEST, and the changes are not taking effect!

    This problem exists on two forms, and I need resolution as soon as possible!

    "Harnessing Request for Quote"

    "Harnessing Document Request"

  • Profile Image
    aubreybourke
    Answered on January 16, 2018 at 09:58 AM

    Note that sending a test email will send to the account email.

    1516114899The Easiest Online Form Builde

    The account email is the one set in your user profile settings.

    1516114659JotForm · My Account - Chromi

     

    If you want to know if a notification/autoresponder is working you need to actually do a test submission of your form. 

  • Profile Image
    dalerheaume
    Answered on January 16, 2018 at 10:04 AM

    Yes, and a test was sent last evening and this morning with same undesired results.

    readychains@igus.com address was removed, but continues to receive.

    jciringione@igus.net address was added, but does not receive!

    This is not the first instance of this troublesome glitch.

    Please dig deeper in the code or execution to resolve this problem

  • Profile Image
    Marvih
    Answered on January 16, 2018 at 10:41 AM

    That is because your Notification Email is bound to a "Change Email Recipient" conditional.

    1516117186468.png

    Please edit the Recipients from your Change Email Recipient conditional.

    1516117225469.png

    Be sure each email address you added is separated by comma "," .


    Let us know how it goes.