Multiple email recipients added by the sub-user resets to one email address only

  • Profile Image
    JJSupport
    Asked on January 15, 2018 at 03:36 PM

    Hello,

    I have added a second email: office@jandjvendinginc.com to our jot forms multiple times however it seems to disappear. I just chatted with an agent Mike (Transcript ID: T1a11IOdSnehHRB60v5z60X00k1ov6Kj) and he also added in the second email to one form for Roostify. However, now that I refresh the page a second time the email has disappeared.

    How can we rectify this and get the second email added on to all of our forms?

    I'm including one link to one form but we have multiple forms to update:

    https://www.jotform.com/build/73517157584161/settings/emails


    Screenshot is also attached showing the 2nd email is no longer there which the agent had added in for me.

    Thanks,

    Mehreen

  • Profile Image
    EltonCris
    Answered on January 15, 2018 at 04:41 PM

    Thanks. I was able to reproduce the problem. I have now escalated this to our developers. You will be informed here once this is fixed.

    I think it is a bug with the sub-account. Since your sub-account is on the free plan and free plan can only add one recipient email address as the recipient, the system resets the email recipient to one even if the form belongs to a paid account.


  • Profile Image
    JJSupport
    Answered on January 16, 2018 at 01:43 PM
    Thanks for sending over this information. Is there an ETA as to when this
    bug may be resolved? Or any workarounds in the meantime?
    ...
  • Profile Image
    BDAVID
    Answered on January 16, 2018 at 02:20 PM

    Unfortunately, there isn't an ETA as to when this bug will be resolved. Probably, the only workaround would be adding the multiple recipients from your main account.

  • Profile Image
    arif
    Answered on January 17, 2018 at 06:46 AM

    Hi,

    This is fixed now. Could you please check and respond?

    Regards

    Arif

  • Profile Image
    JJSupport
    Answered on January 19, 2018 at 02:20 PM

    Sorry about the delay in responding. Unfortunately, no it does not seem to be fixed. See attached screenshot sending to the other email instead of the one listed and saved. I have tried on two different Jot Forms and received the same results.The test email is also actually sent to the support@ email rather than office@ as requested.

    15163894842018-01-19.png

  • Profile Image
    Mike
    Answered on January 19, 2018 at 03:25 PM

    This is how it is designed in our system, the test emails are being sent to the account email address. The real submissions are being emailed to the specified recipient(s). In other words, you can submit the form to test the email delivery.

    The issue where multiple recipients are not saved when added from within the sub-account is supposed to be fixed.

    If you need any further assistance on this, please let us know. We will be happy to help.

  • Profile Image
    JJSupport
    Answered on January 19, 2018 at 03:57 PM

     Oh, you would think the test email would go to the email you enter.

    I did send an actual form and we did receive it at both email addresses. Thanks for fixing this so quickly!


    Mehreen

  • Profile Image
    BDAVID
    Answered on January 19, 2018 at 04:05 PM

    On behalf of our development team, you are welcome! Open a new thread if you need anything else, we will be glad to assist you.