Translation error

  • Profile Image
    Eng. Cosmin Cîmpianu 
    Asked on January 18, 2018 at 06:04 AM

    Hello,

    My question is related to the following menu: in the form editor, settings, show more options (bottom of the page), translations menu, click edit, add form language.

    In this menu I added Portuguese as a form language and proceeded to fill in the fields. After completing the fields that needed translation I went into preview mode but the Portuguese version form wouldn't assume the translation. I went back into the translations menu and the fields that I have previously completed were empty and at the top of the page where you have the green text saying when the last time the changes were saved was a time before I filled in the fields. It's like it didn't saved the changes. I tried again and again to fill in the fields and instead of going directly into preview mode, I would click on the arrow to go back to the previous menu, or click on build at the top of the page but it was futile. The system still wouldn't save the changes.

    What should I do?


    Sincerely,

    Eng. Cosmin Cîmpianu

    P.S.: I also tried to add Portuguese(Portugal) as a language in the menu but after filling the fields I've got the same result.

  • Profile Image
    Ardian_L
    Answered on January 18, 2018 at 09:03 AM

    I have cleared the cache of your form and the translations are working fine now. You need to translate some other fields as well that aren't translated. For example: Personal Information, Mailing address etc.

    Please check the article below on how to clear your form's cache:

    https://www.jotform.com/help/229-How-to-Clear-Your-Form-Cache

    Let us know if you have any other question.