Square Payment Error: Field must not be greater than 60 length

  • Profile Image
    mkellykelly
    Asked on January 19, 2018 at 03:24 PM

    I am trying to square integration and have in the past, but now it is showing the Payment Error.   I see in message boards this has happened in the past.  

    https://www.jotform.com/answers/1314759-Square-payment-Receiving-error-Field-must-not-be-greater-than-60-length-on-submitting

    Can you please quickly resolve this.

  • Profile Image
    aubreybourke
    Answered on January 19, 2018 at 04:16 PM

    I have notified Level 2 support about this issue. It seems this is an error on our side. And should be resolved soon. We will inform you of any progress.

  • Profile Image
    mkellykelly
    Answered on January 19, 2018 at 07:19 PM

    Any updates?  This has caused delays in getting my form out.   We are trying to raise funds and are short on times as is.

  • Profile Image
    John_Benson
    Answered on January 19, 2018 at 09:44 PM

    Unfortunately, we still do not have any updates regarding on this issue. However, we will try our best to notify you on this thread once we have an update. 

    Thank you.

  • Profile Image
    mkellykelly
    Answered on January 20, 2018 at 10:22 AM

    I need to get this form up and running and I am waiting on Jotform's response.   Can you please update me?   This was a problem you had a month ago per my link above and would have thought you would have addressed it already.   

  • Profile Image
    mkellykelly
    Answered on January 20, 2018 at 11:02 AM

    Very frustrating waiting on this.    If this is how service is handled than I may have to cancel my account.

  • Profile Image
    John_Benson
    Answered on January 20, 2018 at 01:56 PM

    Unfortunately, we still do not have any updates on this issue.

    Just an added question, are you experiencing this on all of your forms that has Square integration?

    Could you please try cloning the form and re-add the Square integration to test it further? 

    Here's a guide on how to clone the form: https://www.jotform.com/help/42-How-to-Clone-an-Existing-Form-from-a-URL

    Here's a guide on how to integrate Square: https://www.jotform.com/help/459-How-to-Integrate-Form-with-Square

    Give it a try and let us know how it goes. Thank you.

  • Profile Image
    Mark Kelly
    Answered on January 20, 2018 at 04:27 PM

    This is a problem on your side and don’t feel I should be having to troubleshoot this like this.  I saw several messages from others complaining about same thing and I listed a link from prior person dated 12/5 experiencing same issue.   I did disconnect the square connection last night and reconnected it with positive results, but I am looking for confirmation that the issue has been identified.   I was about to release this for distribution and don’t want to get into my own troubleshooting when this error shows again.

  • Profile Image
    John_Benson
    Answered on January 20, 2018 at 09:35 PM

    Is the issue resolved? 

    The issue has been escalated to our developers. We will contact you again on this thread once we have any updates.

    Thank you.

  • Profile Image
    mkellykelly
    Answered on January 20, 2018 at 09:39 PM

    I don't know for sure as I have not shared the form yet.   The original person who had problems was able to get an order through, but it did not leave me very confident.  I was looking for a response from jot telling me they have identified the issue.   I don't want to have a live form out and then have problems as truthfully your support is not getting me answers very quickly.   

  • Profile Image
    John_Benson
    Answered on January 21, 2018 at 12:25 AM

    Once the issue has been identified by our developers, we will contact you again on this thread.

    Thank you.

  • Profile Image
    CCFRegistration
    Answered on January 21, 2018 at 04:42 PM

    I am having the same issue. A mastercard payment went through but a visa got held up with this error repeatedly. Is it a vendor specific issue? We are also using square.  ETA on a fix?
  • Profile Image
    Jim_R
    Answered on January 21, 2018 at 06:25 PM

    @CCFRegistration - To properly track bug reports separately and to give way to the OP of this thread, I moved your post to a separate thread:

    https://www.jotform.com/answers/1356650

    We'll reply to you there shortly.

  • Profile Image
    SAIadmin
    Answered on January 21, 2018 at 07:07 PM

    I need this answer also, but I can't access the new thread to look for updates.  Says unauthorized access, and I am logged in. 

    I've had this happen to only 3 people out of hundreds.  I thought maybe the whole thing was rejecting because a field somewhere was not set side enough.  The first 2 people who reported it had lengthier than normal email addresses.  However the 3rd one was very normal. 

    Could it be another field causing the error, long address or school name?  Or is it for sure in the payment integration.  If so, why only 3 people affected and tons of others working fine?

  • Profile Image
    omur
    Answered on January 22, 2018 at 01:08 AM

    Hello,

    Thank you for the time you've taken to write us. 

    Your form was indeed hitting an error message of the Square API in some rare cases.


    I've pushed an update to our code base that should prevent this error from happening again.


    Could you please test your form to see if you're encountering this error?

    We're looking forward to your reply.


    If you have any further question, feel free to ask.

    Thank you

  • Profile Image
    SAIadmin
    Answered on January 24, 2018 at 12:37 AM

    I am still having this problem.  I use Jot Forms with 2 different Square accounts.  While one seemed to be fixed last night, the other started with problems today.  I definitely need to get it fixed ASAP!  It seems so random though, so hard to test and know when it's working, just when you think it is you're hearing from someone else about an error code.  :(

    It has to be something conditional based upon their entries.  As I mentioned before ... out of 176 submissions, 3 got the error code while others kept working fine.  ???